summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-12-26 20:53:49 +0100
committerChristopher Arndt2020-12-26 20:53:49 +0100
commitb333d99f94f9594f49f15bae045f36d4d914844e (patch)
tree39d2f0232c99d6864c0a4c29e213f0de4bd0bad1
parent168f52f9458bab5dd5835910bb8b9736e24951c4 (diff)
downloadaur-liblscp-svn.tar.gz
Various fixes and adaptions to upstream changes
* Fix license field * Fix provides for compatibility with community non-VCS package * Fix pkgver() function * Fix compilation commands
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD14
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9264711edf8f..0cb27527afe0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
-# Generated by mksrcinfo v8
-# Thu May 26 15:05:42 UTC 2016
pkgbase = liblscp-svn
pkgdesc = LinuxSampler Control Protocol (LSCP) wrapper library
- pkgver = 0.5.7.1.2923
+ pkgver = 0.9.0.r3843
pkgrel = 1
url = http://www.linuxsampler.org/
arch = i686
arch = x86_64
- license = LGPL
+ license = LGPL2.1
makedepends = subversion
makedepends = doxygen
makedepends = libtool
depends = glibc
provides = liblscp
+ provides = liblscp=0.9.0
+ provides = liblscp.so
conflicts = liblscp
- options = !libtool
source = liblscp::svn+https://svn.linuxsampler.org/svn/liblscp/trunk
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = liblscp-svn
diff --git a/.gitignore b/.gitignore
index 70162b839df0..49923b662c09 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
pkg/
src/
liblscp/
-liblscp-svn*.tar.xz
+liblscp-svn*.pkg.tar.xz
+liblscp-svn*.pkg.tar.zst
liblscp-svn*.src.tar.xz
.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
index 81b8f3c6a73e..df7d72278fce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,30 @@
_pkgname=liblscp
pkgname="${_pkgname}-svn"
-pkgver=0.5.7.1.2923
+pkgver=0.9.0.r3843
pkgrel=1
pkgdesc="LinuxSampler Control Protocol (LSCP) wrapper library"
arch=('i686' 'x86_64')
url="http://www.linuxsampler.org/"
-license=('LGPL')
+license=('LGPL2.1')
depends=('glibc')
makedepends=('subversion' 'doxygen' 'libtool')
conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-options=('!libtool')
+provides=("${_pkgname}" "${_pkgname}=${pkgver/\.r*/}" 'liblscp.so')
source=("${_pkgname}::svn+https://svn.linuxsampler.org/svn/${_pkgname}/trunk")
-md5sums=('SKIP')
+sha256sums=('SKIP')
+
pkgver() {
cd "$srcdir/${_pkgname}"
- echo $(sed -n 's/AM_INIT_AUTOMAKE.*, \(.*\))/\1/p' configure.ac).$(svnversion)
+ echo $(grep '^AC_INIT' configure.ac | cut -d , -f 2).r$(svnversion)
}
build() {
cd "$srcdir/${_pkgname}"
- make -f Makefile.svn
+ ./autogen.sh
./configure --prefix=/usr \
--enable-static=no
make