summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiedleroD2022-12-04 02:45:01 +0100
committerRiedleroD2022-12-04 02:45:01 +0100
commit2dce0ba03cf7df75df0834d72de4f2dbdd2a7776 (patch)
tree8fe1ea32f5e236507b4553fc300964d3931892a0
downloadaur-2dce0ba03cf7df75df0834d72de4f2dbdd2a7776.tar.gz
initial C
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD52
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1253d400f046
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = liblsdj-git
+ pkgdesc = Library for working with the LSDj save file format
+ pkgver = 2.1.0
+ pkgrel = 0
+ url = https://github.com/stijnfrishert/libLSDJ
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ provides = lsdsng-export
+ provides = lsdsng-import
+ provides = lsdj-mono
+ provides = lsdj-wavetable-import
+ source = liblsdj::git+https://github.com/stijnfrishert/libLSDJ.git
+ source = Catch2::git+https://github.com/catchorg/Catch2.git#tag=v2.13.5
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = liblsdj-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcc5b56e7b44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Riedler <dev@riedler.wien>
+
+_pkgname=liblsdj
+pkgname=${_pkgname}-git
+pkgver=2.1.0
+pkgrel=0
+pkgdesc='Library for working with the LSDj save file format'
+arch=('any')
+url='https://github.com/stijnfrishert/libLSDJ'
+license=('MIT')
+provides=('lsdsng-export' 'lsdsng-import' 'lsdj-mono' 'lsdj-wavetable-import')
+depends=()
+makedepends=('cmake' 'git')
+#TODO: set back to original author's repo once they fix the submodule version
+source=("$_pkgname::git+https://github.com/stijnfrishert/libLSDJ.git"
+ "Catch2::git+https://github.com/catchorg/Catch2.git#tag=v2.13.5")
+sha256sums=('SKIP' 'SKIP')
+
+prepare() {
+ rm $_pkgname/dependency/Catch2 -drf
+ mv Catch2 $_pkgname/dependency
+ cd $_pkgname
+ mkdir build -p
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+}
+
+build() {
+ cd $_pkgname
+ cmake --build build --config Release
+}
+
+package() {
+ cd $_pkgname
+ install -Dm644 LICENSE \
+ "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ cd build
+ install -Dm755 "./lsdsng_export/lsdsng-export" \
+ -t "$pkgdir/usr/bin/"
+ install -Dm755 "./lsdsng_import/lsdsng-import" \
+ -t "$pkgdir/usr/bin/"
+ install -Dm755 "./lsdj_wavetable_import/lsdj-wavetable-import" \
+ -t "$pkgdir/usr/bin/"
+ install -Dm755 "./lsdj_mono/lsdj-mono" \
+ -t "$pkgdir/usr/bin/"
+ install -Dm755 "./liblsdj/liblsdj.a" \
+ -t "$pkgdir/usr/lib/"
+}
+
+check() {
+ $_pkgname/build/liblsdj/test/test
+} \ No newline at end of file