summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoic Blot2017-06-22 07:29:19 +0200
committerLoic Blot2017-06-22 07:31:02 +0200
commit9694cc4153fc9a3ea49d7d87600c8a799b571c7b (patch)
tree54a54cb27b81854ad715e3082b1da6164905417f
downloadaur-9694cc4153fc9a3ea49d7d87600c8a799b571c7b.tar.gz
Add PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45d7ac3e9dfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libluasandbox
+ pkgdesc = Generic Lua sandbox for dynamic data analysis
+ pkgver = 1.2.5
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = MPL
+ makedepends = cmake
+ source = https://github.com/mozilla-services/lua_sandbox/archive/v1.2.5.tar.gz
+ sha256sums = 9a63b37f1b9b6d40afa45f92e3777f3baf770d195cb41fad04a0e020d398ebed
+
+pkgname = libluasandbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6010312528ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Loic Blot <loic.blot@unix-experience.fr>
+pkgname=libluasandbox
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="Generic Lua sandbox for dynamic data analysis"
+source=("https://github.com/mozilla-services/lua_sandbox/archive/v$pkgver.tar.gz")
+sha256sums=('9a63b37f1b9b6d40afa45f92e3777f3baf770d195cb41fad04a0e020d398ebed')
+arch=('i686' 'x86_64')
+license=('MPL')
+makedepends=('cmake')
+
+_buildroot="release"
+build() {
+ cd lua_sandbox-$pkgver
+ mkdir $_buildroot
+ cd $_buildroot
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
+ make
+}
+
+package() {
+ cd lua_sandbox-${pkgver}/${_buildroot}
+ make install
+}