summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Martin2015-10-09 22:59:44 -0400
committerPaul Martin2015-10-09 22:59:44 -0400
commit41333bc5666fa17c622a44d87fa168e1bad37377 (patch)
treec7be5662bce1d8fc02abd6f657ec917b1de77300
downloadaur-41333bc5666fa17c622a44d87fa168e1bad37377.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b39ec2809651
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libmacaroons
+ pkgdesc = Libmacaroons provides flexible authorization credentials that support decentralized delegation, attenuation, and verification, and is used by HyperDex.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/rescrv/libmacaroons
+ arch = x86_64
+ arch = i686
+ license = BSD
+ makedepends = wget
+ makedepends = gcc
+ source = http://hyperdex.org/src/libmacaroons-0.3.0.tar.gz
+ md5sums = 99e86f7813366f1d17bb4164bab63d7a
+
+pkgname = libmacaroons
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f1864bb0ec4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57c707d746cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: MobiusHorizons <codemobius@gmail.com>
+pkgname=libmacaroons
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Libmacaroons provides flexible authorization credentials that support decentralized delegation, attenuation, and verification, and is used by HyperDex."
+url="https://github.com/rescrv/libmacaroons"
+arch=('x86_64' 'i686')
+license=('BSD')
+depends=()
+makedepends=('wget' 'gcc')
+conflicts=()
+replaces=()
+backup=()
+source=("http://hyperdex.org/src/${pkgname}-${pkgver}.tar.gz")
+md5sums=('99e86f7813366f1d17bb4164bab63d7a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: