summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Pohl2019-11-27 21:55:13 +0100
committerAlexander Pohl2019-11-27 21:55:13 +0100
commit68144733b3cd8ec0bd0ac3727c358fc4473dac5f (patch)
tree7b85f0bde69a0eb86fd665314a159f5f68b0dff7
downloadaur-68144733b3cd8ec0bd0ac3727c358fc4473dac5f.tar.gz
intitial package upload to aur
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8a808e17db9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libmag3110
+ pkgdesc = A C++ library for the MAG3110 SparkFun 3-axis magnetometer breakout board
+ pkgver = 0.1.7
+ pkgrel = 1
+ url = https://ahpohl.github.io/mag3110/
+ arch = aarch64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ source = libmag3110-0.1.7::git+https://github.com/ahpohl/mag3110.git#tag=v0.1.7
+ sha256sums = SKIP
+
+pkgname = libmag3110
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7da7292a54bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alexander Pohl <alex at ahpohl dot com>
+pkgname=libmag3110
+pkgver=0.1.7
+pkgrel=1
+epoch=
+pkgdesc="A C++ library for the MAG3110 SparkFun 3-axis magnetometer breakout board"
+arch=('aarch64' 'armv6h' 'armv7h')
+url="https://ahpohl.github.io/mag3110/"
+license=('GPL3')
+groups=()
+depends=()
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+https://github.com/ahpohl/mag3110.git#tag=v${pkgver}")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+ install -Dm644 LICENSE "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+ install -Dm644 include/mag3110.hpp "$pkgdir"/usr/include/mag3110
+}