summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorΝικόλαος Κυριάκος Φυτίλης2016-08-09 11:26:19 +0300
committerΝικόλαος Κυριάκος Φυτίλης2016-08-09 11:26:19 +0300
commit8d9af13753cb5b59abdd802dc77fd015537a5cc8 (patch)
tree83bd2670340ae02116d21ba491e671a631890ed5
downloadaur-8d9af13753cb5b59abdd802dc77fd015537a5cc8.tar.gz
auto - see github.com/nicman23/mate_arch
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD43
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c361bacfc612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = libmateweather-dev
+ pkgdesc = Provides access to weather information from the Internet (GTK3 version)
+ pkgver = 1.15.0
+ pkgrel = 2
+ url = http://mate-desktop.org
+ arch = i686
+ arch = x86_64
+ groups = mate-extra
+ license = LGPL
+ makedepends = mate-common-dev
+ depends = dconf
+ depends = gtk3
+ depends = libsoup
+ depends = glib2
+ depends = gtk-update-icon-cache
+ provides = libmateweather
+ provides = libmateweather-gtk3
+ conflicts = libmateweather
+ conflicts = libmateweather-gtk3
+ source = http://pub.mate-desktop.org/releases/1.15/libmateweather-1.15.0.tar.xz
+ sha1sums = ad4357c0a2e2d5c61b601b4b8fddbd409b82186f
+
+pkgname = libmateweather-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3694c7a9487
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Νικόλαος Κυριάκος Φυτίλης <n-fit@live.com>
+# Contributor: eadrom <eadrom@archlinux.info>
+# Contributor: Martin Wimpress <code@flexion.org>
+
+_ver=1.15
+_pkgbase=libmateweather
+pkgname="${_pkgbase}-dev"
+pkgver=${_ver}.0
+pkgrel=2
+pkgdesc="Provides access to weather information from the Internet (GTK3 version)"
+url="http://mate-desktop.org"
+arch=('i686' 'x86_64')
+provides=("${_pkgbase}" "${_pkgbase}-gtk3")
+conflicts=("${_pkgbase}" "${_pkgbase}-gtk3")
+license=('LGPL')
+depends=('dconf' 'gtk3' 'libsoup' 'glib2' 'gtk-update-icon-cache')
+groups=('mate-extra')
+makedepends=('mate-common-dev')
+source=("http://pub.mate-desktop.org/releases/${_ver}/${_pkgbase}-${pkgver}.tar.xz")
+sha1sums=('ad4357c0a2e2d5c61b601b4b8fddbd409b82186f')
+
+prepare() {
+ cd "${srcdir}"
+ mv "${_pkgbase}-${pkgver}" "${_pkgbase}-gtk3"
+}
+
+build() {
+ cd "${srcdir}/${_pkgbase}-gtk3"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-gtk=3.0 \
+ --disable-static \
+ --disable-python \
+ --enable-locations-compression
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-gtk3"
+ make DESTDIR="${pkgdir}" install
+}