summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2024-04-18 19:23:42 +0100
committerWorMzy Tykashi2024-04-18 19:24:12 +0100
commit9989d93a8589b5d14a5c325d0820b5a6cc7684b4 (patch)
tree2d6fb745f94a8a28efabfe88068ec990ae243f67
parent0f2cceb041a9d443cfa6f10212f334c41888c901 (diff)
downloadaur-libmatheval.tar.gz
Switch to Debian's patchset for fixes and updates
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--removeifndefs.patch30
-rw-r--r--replace-obsolete-functions.patch33
4 files changed, 34 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7c318b3f8df..25f66a238487 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,25 @@
pkgbase = libmatheval
pkgdesc = A C/Fortran library to parse and evaluate symbolic expressions input as text.
pkgver = 1.1.11
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/libmatheval/
arch = i686
arch = x86_64
- license = GPL3
- makedepends = guile2.0
+ license = GPL-3.0-or-later
+ makedepends = guile
depends = flex
+ depends = glibc
source = https://ftp.gnu.org/gnu/libmatheval/libmatheval-1.1.11.tar.gz
- source = removeifndefs.patch
- source = replace-obsolete-functions.patch
+ source = https://sources.debian.org/data/main/libm/libmatheval/1.1.11%2Bdfsg-5/debian/patches/002-skip-docs.patch
+ source = https://sources.debian.org/data/main/libm/libmatheval/1.1.11%2Bdfsg-5/debian/patches/003-guile3.0.patch
+ source = https://sources.debian.org/data/main/libm/libmatheval/1.1.11%2Bdfsg-5/debian/patches/disable_coth_test.patch
md5sums = 595420ea60f6ddd75623847f46ca45c4
- md5sums = b340ca489388a8c7986654f4be8127f4
- md5sums = 5a58a75ad710d8847be3931944404429
+ md5sums = e25aacf73d881a8badc3223601e69863
+ md5sums = ea2d6e48e91e734677749fcdc5acb375
+ md5sums = c01c49fe5684929042d9f041452cb381
+ sha1sums = d4720860403c36ebe955b1b5c31c6c3ca20b2a25
+ sha1sums = 9c49f98d74ed076f710ec8eb499edc46ce4d0af5
+ sha1sums = 058612ff66bbb49a032583ef14f7de2c6fbf43d9
+ sha1sums = df4f4a9a76cec4d6b583135b7a03ed3472031815
pkgname = libmatheval
-
diff --git a/PKGBUILD b/PKGBUILD
index 282ddba9d80a..47994c04c44f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,37 @@
pkgname=libmatheval
pkgver=1.1.11
-pkgrel=1
+pkgrel=2
pkgdesc="A C/Fortran library to parse and evaluate symbolic expressions input as text."
arch=('i686' 'x86_64')
url="https://www.gnu.org/software/libmatheval/"
-license=('GPL3')
-depends=('flex')
-makedepends=('guile2.0')
+license=('GPL-3.0-or-later')
+depends=('flex' 'glibc')
+makedepends=('guile')
source=("https://ftp.gnu.org/gnu/libmatheval/${pkgname}-${pkgver}.tar.gz"
- "removeifndefs.patch"
- "replace-obsolete-functions.patch")
+ https://sources.debian.org/data/main/libm/libmatheval/1.1.11%2Bdfsg-5/debian/patches/002-skip-docs.patch
+ https://sources.debian.org/data/main/libm/libmatheval/1.1.11%2Bdfsg-5/debian/patches/003-guile3.0.patch
+ https://sources.debian.org/data/main/libm/libmatheval/1.1.11%2Bdfsg-5/debian/patches/disable_coth_test.patch
+ )
md5sums=('595420ea60f6ddd75623847f46ca45c4'
- 'b340ca489388a8c7986654f4be8127f4'
- '5a58a75ad710d8847be3931944404429')
+ 'e25aacf73d881a8badc3223601e69863'
+ 'ea2d6e48e91e734677749fcdc5acb375'
+ 'c01c49fe5684929042d9f041452cb381')
+sha1sums=('d4720860403c36ebe955b1b5c31c6c3ca20b2a25'
+ '9c49f98d74ed076f710ec8eb499edc46ce4d0af5'
+ '058612ff66bbb49a032583ef14f7de2c6fbf43d9'
+ 'df4f4a9a76cec4d6b583135b7a03ed3472031815')
prepare() {
- cd "${pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/removeifndefs.patch"
- patch -p1 -i "${srcdir}/replace-obsolete-functions.patch"
+ cd ${pkgname}-${pkgver}
+ patch -p1 -i "${srcdir}/002-skip-docs.patch"
+ patch -p1 -i "${srcdir}/003-guile3.0.patch"
+ patch -p1 -i "${srcdir}/disable_coth_test.patch"
}
build() {
cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr GUILE=/usr/bin/guile2.0 GUILE_CONFIG=/usr/bin/guile-config2.0
+ ./configure --prefix=/usr GUILE=/usr/bin/guile GUILE_CONFIG=/usr/bin/guile-config
make
}
diff --git a/removeifndefs.patch b/removeifndefs.patch
deleted file mode 100644
index 418a3bb06e6f..000000000000
--- a/removeifndefs.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -aur a/tests/matheval.c b/tests/matheval.c
---- a/tests/matheval.c 2016-03-24 13:55:00.163074189 +0000
-+++ b/tests/matheval.c 2016-03-24 13:52:59.492996682 +0000
-@@ -26,26 +26,6 @@
- #include <matheval.h>
- #include "config.h"
-
--#ifndef HAVE_SCM_T_BITS
--typedef long scm_t_bits;
--#endif
--
--#ifndef HAVE_SCM_NUM2DBL
--#ifdef SCM_NUM2DBL
--#define scm_num2dbl(x,s) SCM_NUM2DBL(x)
--#else
--#error Neither scm_num2dbl() nor SCM_NUM2DBL available
--#endif
--#endif
--
--#ifndef HAVE_SCM_C_DEFINE_GSUBR
--#ifdef HAVE_SCM_MAKE_GSUBR
--#define scm_c_define_gsubr scm_make_gsubr
--#else
--#error Neither scm_c_define_gsubr() nor scm_make_gsubr() available
--#endif
--#endif
--
- static scm_t_bits evaluator_tag; /* Unique identifier for Guile
- * objects of evaluator type. */
-
diff --git a/replace-obsolete-functions.patch b/replace-obsolete-functions.patch
deleted file mode 100644
index c1039cc1fdb9..000000000000
--- a/replace-obsolete-functions.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -aur 1/tests/matheval.c 2/tests/matheval.c
---- 1/tests/matheval.c 2013-08-14 21:22:08.000000000 +0100
-+++ 2/tests/matheval.c 2017-12-30 21:01:53.333215271 +0000
-@@ -51,7 +51,7 @@
-
- /* Guile interface for libmatheval library. Procedures below are simple
- * wrappers for corresponding libmatheval procedures. */
--static scm_sizet evaluator_destroy_scm(SCM evaluator_smob);
-+static size_t evaluator_destroy_scm(SCM evaluator_smob);
- static SCM evaluator_create_scm(SCM string);
- static SCM evaluator_evaluate_scm(SCM evaluator_smob, SCM count,
- SCM names, SCM values);
-@@ -122,7 +122,7 @@
- }
-
- /* Wrapper for evaluator_destroy() procedure from libmatheval library. */
--static scm_sizet
-+static size_t
- evaluator_destroy_scm(SCM evaluator_smob)
- {
- SCM_ASSERT((SCM_NIMP(evaluator_smob)
-@@ -245,9 +245,9 @@
- list = SCM_EOL;
- for (i = 0; i < count; i++)
- list =
-- scm_append_x(scm_listify
-+ scm_append_x(scm_list_n
- (list,
-- scm_listify(scm_makfrom0str(names[i]),
-+ scm_list_n(scm_makfrom0str(names[i]),
- SCM_UNDEFINED),
- SCM_UNDEFINED));
-