summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2021-01-07 21:52:07 +0100
committerMorten Linderud2021-01-07 21:52:07 +0100
commit0d44c89a5990e3a9db7f0dee6c975196c4b697fc (patch)
tree36bbcda33ce5f1863b499373bdd48a0ebe42b1b0
parent8b5aee3685121691e6e3b1ba48c3b47681aa1ab3 (diff)
downloadaur-0d44c89a5990e3a9db7f0dee6c975196c4b697fc.tar.gz
import from community
-rw-r--r--.SRCINFO14
-rw-r--r--ChangeLog35
-rw-r--r--PKGBUILD34
3 files changed, 60 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50d23720a89f..788e393ddb58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = libmatio
pkgdesc = C library with a fortran 90/95 module interface for reading/writing MATLAB MAT-files
- pkgver = 1.5.2
- pkgrel = 3
- url = http://sourceforge.net/projects/matio
+ pkgver = 1.5.17
+ pkgrel = 1
+ url = https://sourceforge.net/projects/matio
+ changelog = ChangeLog
arch = x86_64
- arch = i686
license = custom:BSD
depends = zlib
depends = hdf5
- options = !libtool
options = !emptydirs
- source = http://downloads.sourceforge.net/matio/matio-1.5.2.tar.gz
- sha1sums = d5a83a51eb2550d75811d2dde967ef3e167d4f52
+ source = https://downloads.sourceforge.net/matio/matio-1.5.17.tar.gz
+ sha512sums = af8ff11c7c44fea9ea6886e381f49ef9186946f3def98ad9695f2d5d1df045c35e8f4ceac12a44be397f7bbd708b4803762b5ce54c45b60a9f446d551c04f5d2
pkgname = libmatio
-
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..1eb3d8c74928
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,35 @@
+1.5.14-1:
+upstream update
+
+1.5.13-1:
+upstream update
+
+1.5.12-3:
+hdf5 rebuild
+
+1.5.12-1:
+upstream update
+
+1.5.11-1:
+upstream update
+
+1.5.10-2:
+hdf5 rebuild
+
+1.5.10-1:
+upstream update
+
+1.5.9-1:
+upstream update
+
+1.5.8-1:
+upstream update
+
+1.5.6-2:
+rebuild against the newest hdf5
+
+1.5.6-1:
+upstream update
+
+1.5.2-3:
+move from AUR to [community]
diff --git a/PKGBUILD b/PKGBUILD
index 493da233c2d5..a6ec09c50006 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-# Contributor: Alexander Rødseth <rodseth@gmail.com>
-# Contributor: William Rea <sillywilly@gmail.com>
+# Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
+# Contributor: Alexander Rødseth <rodseth at gmail dot com>
+# Contributor: William Rea <sillywilly at gmail dot com>
pkgname=libmatio
-pkgver=1.5.2
-pkgrel=3
+pkgver=1.5.17
+pkgrel=1
pkgdesc='C library with a fortran 90/95 module interface for reading/writing MATLAB MAT-files'
-arch=('x86_64' 'i686')
+arch=('x86_64')
license=('custom:BSD')
-url='http://sourceforge.net/projects/matio'
+url='https://sourceforge.net/projects/matio'
depends=('zlib' 'hdf5')
-options=('!libtool' '!emptydirs')
-source=("http://downloads.sourceforge.net/matio/matio-$pkgver.tar.gz")
-sha1sums=('d5a83a51eb2550d75811d2dde967ef3e167d4f52')
+options=('!emptydirs')
+source=("https://downloads.sourceforge.net/matio/matio-${pkgver}.tar.gz")
+changelog=ChangeLog
+sha512sums=('af8ff11c7c44fea9ea6886e381f49ef9186946f3def98ad9695f2d5d1df045c35e8f4ceac12a44be397f7bbd708b4803762b5ce54c45b60a9f446d551c04f5d2')
build() {
- cd matio-$pkgver
+ cd "matio-${pkgver}"
./configure --prefix=/usr --enable-shared --with-hdf5
make
}
-
+
package() {
- cd matio-$pkgver
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ cd "matio-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/usr/share/info/dir"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
+