summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCamille Monière2021-02-08 11:54:28 +0100
committerCamille Monière2021-02-08 11:54:28 +0100
commita23c6c5e88675acfc717586e6dddfe5bf5ed8add (patch)
tree8d3f0a279e59af645caee83973d01a5c539c5d0e
downloadaur-a23c6c5e88675acfc717586e6dddfe5bf5ed8add.tar.gz
Create package for first release of matioCpp
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD53
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4e35aeca6c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libmatio-cpp
+ pkgdesc = A C++ wrapper of the matio library, with memory ownership handling.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/dic-iit/matio-cpp
+ arch = x86_64
+ license = BSD
+ checkdepends = catch2
+ makedepends = cmake
+ depends = libmatio
+ provides = libmatio-cpp
+ conflicts = libmatio-cpp-git
+ source = libmatio-cpp-0.1.0.tar.gz::https://github.com/dic-iit/matio-cpp/archive/v0.1.0.tar.gz
+ sha256sums = d5d23bca15fd94c1cf8eb88070ca5f31c180c4cdf17db2c4d1edce865fe65f4c
+
+pkgname = libmatio-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0ded78b3d14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Camille 'DrasLorus' Monière <draslorus@draslorus.fr>
+
+pkgname=libmatio-cpp
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A C++ wrapper of the matio library, with memory ownership handling."
+arch=('x86_64')
+url="https://github.com/dic-iit/matio-cpp"
+license=('BSD')
+groups=()
+depends=('libmatio')
+makedepends=('cmake')
+checkdepends=('catch2')
+provides=("$pkgname")
+conflicts=("$pkgname-git")
+replaces=()
+backup=()
+options=()
+install=
+source=('libmatio-cpp-0.1.0.tar.gz::https://github.com/dic-iit/matio-cpp/archive/v0.1.0.tar.gz')
+noextract=()
+sha256sums=('d5d23bca15fd94c1cf8eb88070ca5f31c180c4cdf17db2c4d1edce865fe65f4c')
+
+prepare() {
+ cd "$srcdir"
+ mv matio-cpp-"$pkgver" "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -B build -S . -DCMAKE_BUILD_TYPE=None \
+ -Wno-dev \
+ -DCMAKE_GENERATOR="Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build -j
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cmake -B build_testing -S . -DCMAKE_BUILD_TYPE=None \
+ -Wno-dev \
+ -DCMAKE_GENERATOR="Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTING=ON
+ cmake --build build_testing -j
+ cd build_testing && ctest
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}