summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrasLorus2021-01-27 17:05:05 +0100
committerDrasLorus2021-01-27 17:05:05 +0100
commit04f5dc35514340d25a035485263aa5e01745ab97 (patch)
tree1322743c5056b32c1419d4f08c5e3409b20b106e
downloadaur-04f5dc35514340d25a035485263aa5e01745ab97.tar.gz
Initial Commit
- Provide PKGBUILD and .SRCINFO - Has a known issue with v7.3 and strings as current version from 27th of January 2021. Thats why the test 8 is avoided.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD52
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c3b6f5c5725
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libmatio-cpp-git
+ pkgdesc = A C++ wrapper of the matio library, with memory ownership handling.
+ pkgver = r161.949f9e5
+ pkgrel = 1
+ url = https://github.com/dic-iit/matio-cpp
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ depends = libmatio
+ provides = libmatio-cpp
+ conflicts = libmatio-cpp
+ source = libmatio-cpp::git+https://github.com/dic-iit/matio-cpp
+ md5sums = SKIP
+
+pkgname = libmatio-cpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..230492769508
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Camille 'DrasLorus' Monière <draslorus@draslorus.fr>
+
+pkgname=libmatio-cpp-git
+pkgver=r161.949f9e5
+pkgrel=1
+pkgdesc="A C++ wrapper of the matio library, with memory ownership handling."
+arch=('x86_64')
+url="https://github.com/dic-iit/matio-cpp"
+license=('BSD')
+groups=()
+depends=('libmatio')
+makedepends=('git'
+ 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('libmatio-cpp::git+https://github.com/dic-iit/matio-cpp')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S "${pkgname%-git}" -DCMAKE_BUILD_TYPE=None \
+ -Wno-dev \
+ -DCMAKE_GENERATOR="Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build -j
+}
+
+check() {
+ cmake -B build_testing -S "${pkgname%-git}" -DCMAKE_BUILD_TYPE=None \
+ -Wno-dev \
+ -DCMAKE_GENERATOR="Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTING=ON
+ cmake --build build_testing -j
+ # Test 8 fails because of unsupported v7.3 format
+ cd build_testing && ctest -I 1,7,1,9,10,11
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 "$srcdir/${pkgname%-git}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}