summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-03-25 00:47:05 +0800
committerChocobo12021-03-25 00:48:01 +0800
commitcbd528b49f9f69652e691e92f76c257ed50ddd9a (patch)
tree26384ac98ed6d9e95d0b02a4cf50086b90783841
downloadaur-cbd528b49f9f69652e691e92f76c257ed50ddd9a.tar.gz
newpkg: libmatroska-git 1.6.3.r7.g8cf9207-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..517c3d3e5427
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libmatroska-git
+ pkgdesc = C++ libary to parse Matroska files
+ pkgver = 1.6.3.r7.g8cf9207
+ pkgrel = 1
+ url = https://matroska.org/index.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = cmake
+ depends = glibc
+ depends = libebml.so
+ provides = libmatroska
+ provides = libmatroska.so
+ conflicts = libmatroska
+ source = git+https://github.com/Matroska-Org/libmatroska.git
+ sha256sums = SKIP
+
+pkgname = libmatroska-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c4c3eda48d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libmatroska-git
+pkgver=1.6.3.r7.g8cf9207
+pkgrel=1
+pkgdesc="C++ libary to parse Matroska files"
+arch=('i686' 'x86_64')
+url="https://matroska.org/index.html"
+license=('LGPL')
+depends=('glibc' 'libebml.so')
+makedepends=('git' 'cmake')
+provides=('libmatroska' 'libmatroska.so')
+conflicts=('libmatroska')
+source=("git+https://github.com/Matroska-Org/libmatroska.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libmatroska"
+
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libmatroska"
+
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_SHARED_LIBS=ON \
+ ./
+ make -C "_build"
+}
+
+package() {
+ cd "libmatroska"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+}