summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-19 10:54:34 -0500
committerclintval2017-12-19 10:54:34 -0500
commit83e48b7a8ed8ae65ae7dba26ede9ca9d83d40672 (patch)
treec75e170f67bbe2b674878bcd0d7fbed152697add
downloadaur-83e48b7a8ed8ae65ae7dba26ede9ca9d83d40672.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14a1d6624614
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libmaus
+ pkgdesc = Bioinformatics data structures and algorithms in C++
+ pkgver = 2.0.433
+ pkgrel = 1
+ url = https://github.com/gt1/libmaus2
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc-libs
+ provides = libmaus
+ conflicts = libmaus
+ source = https://github.com/gt1/libmaus2/archive/2.0.433-release-20171218125839.tar.gz
+ md5sums = 7ab7575a60d43ca5660019b37958b8a3
+
+pkgname = libmaus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aede5058e6c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname=libmaus
+pkgver=2.0.433
+pkgrel=1
+release=20171218125839
+pkgdesc="Bioinformatics data structures and algorithms in C++"
+arch=('x86_64')
+url="https://github.com/gt1/libmaus2"
+license=('GPL3')
+depends=()
+makedepends=('gcc-libs')
+provides=('libmaus')
+conflicts=('libmaus')
+source=("https://github.com/gt1/${pkgname}2/archive/${pkgver}-release-${release}.tar.gz")
+md5sums=('7ab7575a60d43ca5660019b37958b8a3')
+MAKEFLAGS="-j$(nproc)"
+
+build() {
+ cd "${srcdir}/libmaus2-${pkgver}-release-${release}"
+ ./configure --prefix="${pkgdir}/usr/local" --exec-prefix "${pkgdir}/"
+ make
+}
+
+check() {
+ cd "${srcdir}/libmaus2-${pkgver}-release-${release}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/libmaus2-${pkgver}-release-${release}"
+ make install
+
+ mv "${pkgdir}/lib" "${pkgdir}/usr/lib"
+}