summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-06-21 14:11:40 -0700
committerclintval2018-06-21 14:11:40 -0700
commitf4125ec19a95e834d66d110cc4e0bf43d3f8b31e (patch)
treea1cf70169916c1eddd19eafaef610549c385e76f
parent3df81cac8d1e7b26f287fbb5c1873833b8c68808 (diff)
downloadaur-f4125ec19a95e834d66d110cc4e0bf43d3f8b31e.tar.gz
libmaus to new mirror and 2.0.504
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 667ec01baf4e..92bb84355b69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = libmaus
pkgdesc = Bioinformatics data structures and algorithms in C++
- pkgver = 2.0.442
+ pkgver = 2.0.504
pkgrel = 1
- url = https://github.com/gt1/libmaus2
+ url = https://gitlab.com/german.tischler/libmaus2
arch = x86_64
- license = GPL3
- source = https://github.com/gt1/libmaus2/archive/2.0.442-release-20180115152528.tar.gz
- sha256sums = 17efe43b3a8ab2b6f560931b2936f5d5f1cf59541406cfc02eaac359238593e8
+ license = GPL2
+ source = https://gitlab.com/german.tischler/libmaus2/-/archive/2.0.504-release-20180619115641/libmaus2-2.0.504-release-20180619115641.tar.gz
+ sha256sums = e134287064723593844fd9bff35872e2e618d825e3389166cfbba2b49ff3bcc5
pkgname = libmaus
diff --git a/PKGBUILD b/PKGBUILD
index afeaa010fe36..b1c8fbc6409a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
pkgname=libmaus
-pkgver=2.0.442
+pkgver=2.0.504
pkgrel=1
-_release=20180115152528
+_release=20180619115641
pkgdesc="Bioinformatics data structures and algorithms in C++"
arch=('x86_64')
-url="https://github.com/gt1/libmaus2"
-license=('GPL3')
-source=(https://github.com/gt1/"${pkgname}"2/archive/"${pkgver}"-release-"${_release}".tar.gz)
-sha256sums=('17efe43b3a8ab2b6f560931b2936f5d5f1cf59541406cfc02eaac359238593e8')
-MAKEFLAGS="-j$(nproc)"
+url=https://gitlab.com/german.tischler/libmaus2
+license=('GPL2')
+source=(https://gitlab.com/german.tischler/"${pkgname}"2/-/archive/"${pkgver}"-release-20180619115641/"${pkgname}"2-"${pkgver}"-release-"${_release}".tar.gz)
+sha256sums=('e134287064723593844fd9bff35872e2e618d825e3389166cfbba2b49ff3bcc5')
+
+prepare() {
+ cd "${srcdir}"/libmaus2-"${pkgver}"-release-"${_release}"
+ make clean
+}
build() {
cd "${srcdir}"/libmaus2-"${pkgver}"-release-"${_release}"
@@ -25,6 +29,6 @@ check() {
package() {
cd "${srcdir}"/libmaus2-"${pkgver}"-release-"${_release}"
- make install
- mv "${pkgdir}"/lib "${pkgdir}"/usr/lib
+ make install && mv "${pkgdir}"/lib "${pkgdir}"/usr/lib
+ install -Dm644 AUTHORS "${pkgdir}"/usr/share/licenses/"${pkgname}"2/AUTHORS
}