summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2019-07-26 16:42:35 +0200
committerManuel Reimer2019-07-26 16:42:35 +0200
commit907e14df72f99c1c87c2dabd28c6741d81575430 (patch)
tree965a55642b8adba01fda12e9a95a153e3011fbeb
downloadaur-907e14df72f99c1c87c2dabd28c6741d81575430.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/6d99983f1d0936ec6ee1f34d1083688c1ed8f078)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4b13b5ac5d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 5.1.3
+# Fri Jul 26 14:42:35 UTC 2019
+pkgbase = libmcli
+ pkgdesc = Library and tools to access the REEL NetCeiver
+ pkgver = r189
+ pkgrel = 1
+ url = https://www.baycom.de/hardware/netceiver/
+ arch = x86_64
+ license = GPL2
+ makedepends = subversion
+ depends = libxml2
+ source = svn+https://svn.baycom.de/repos/vdr-mcli-plugin/#revision=189
+ sha256sums = SKIP
+
+pkgname = libmcli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c450023eb36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# -*- mode: shell-script -*-
+pkgname=libmcli
+_svnver=189
+pkgver=r${_svnver}
+pkgrel=1
+pkgdesc='Library and tools to access the REEL NetCeiver'
+url='https://www.baycom.de/hardware/netceiver/'
+arch=('x86_64')
+license=('GPL2')
+depends=('libxml2')
+makedepends=('subversion')
+source=("svn+https://svn.baycom.de/repos/vdr-mcli-plugin/#revision=${_svnver}")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/vdr-mcli-plugin/"
+ find . -name '*.so*' -delete
+}
+
+build() {
+ cd "${srcdir}/vdr-mcli-plugin/mcast/client"
+ make
+
+ cd "${srcdir}/vdr-mcli-plugin/mcast/tool"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-mcli-plugin/mcast/"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "tool/"{netcvdiag,netcvlogview,netcvupdate} "${pkgdir}/usr/bin"
+
+ mkdir -p "${pkgdir}/usr/lib"
+ cp "client/libmcli.so" "${pkgdir}/usr/lib"
+
+ _include="${pkgdir}/usr/include/libmcli/mcast"
+ mkdir -p "$_include"
+ mkdir "$_include/client"
+ mkdir "$_include/common"
+ cp client/*.h "$_include/client"
+ cp common/*.h "$_include/common"
+ chmod -x "${pkgdir}/usr/include/libmcli/mcast/common/crc32.h"
+}