summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Damián Barberón2015-09-01 15:20:22 -0300
committerLeonardo Damián Barberón2015-09-01 15:20:22 -0300
commiteffd22c2a781ad7e91fe089be068f710325b2f65 (patch)
tree06d2aa6dc2951735410701e2bc87000558454429
downloadaur-effd22c2a781ad7e91fe089be068f710325b2f65.tar.gz
init import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a822523789c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libmediaart1
+ pkgdesc = Library tasked with managing, extracting and handling media art caches
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/curlybeast/libmediaart
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = vala
+ makedepends = gobject-introspection
+ depends = gdk-pixbuf2
+ conflicts = libmediaart>=0.7.0
+ source = http://ftp.gnome.org/pub/gnome/sources/libmediaart/0.7/libmediaart-0.7.0.tar.xz
+ sha256sums = 3a9dffcad862aed7c0921579b93080d694b8a66f3676bfee8037867f653a1cd3
+
+pkgname = libmediaart1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a864e1a4c366
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer: Leonardo Damián Barberón (damian01w) <damian01w@gmail.com>
+
+pkgname=libmediaart1
+_pkgname=libmediaart
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Library tasked with managing, extracting and handling media art
+caches"
+arch=('i686' 'x86_64')
+conflicts=('libmediaart>=0.7.0')
+license=('LGPL')
+depends=('gdk-pixbuf2')
+makedepends=('vala' 'gobject-introspection')
+url="https://github.com/curlybeast/libmediaart"
+source=(http://ftp.gnome.org/pub/gnome/sources/$_pkgname/${pkgver:0:3}/$_pkgname-$pkgver.tar.xz)
+sha256sums=('3a9dffcad862aed7c0921579b93080d694b8a66f3676bfee8037867f653a1cd3')
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --disable-static --enable-gdkpixbuf --disable-qt
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+