summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreDgar2021-03-17 16:09:26 -0600
committereDgar2021-03-18 00:27:41 -0600
commit57f38f282b7c3571605f6bf884a4f20fe24e4d4f (patch)
treec1f71021249535df51002a455a198a169be51fa8
parent5866df76f877b74059e8ae36156fc444edf9c754 (diff)
downloadaur-57f38f282b7c3571605f6bf884a4f20fe24e4d4f.tar.gz
add quiet, target directories + move comments of CONFOPTS
-rw-r--r--PKGBUILD83
1 files changed, 57 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89358d312636..5544ce50a85c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -117,41 +117,72 @@ build() {
cd "${buildir}"
CONFOPTS=(
- --enable-petsc-hypre-required # recommended by MOOSE
- --with-metis=PETSc # use PETSCs' metis
- --enable-cxx11-required # force C++11 standard
- --enable-metaphysicl-required # recommended by MOOSE
- --enable-vtk-required
+ --quiet
+ --srcdir="${srcdir}/${realname}"
+ # target directory
+ --prefix=/usr
+ # read-only single-machine data (Make.common)
+ --sysconfdir=/etc/
+ # Binary directory
+ --bindir=/usr/bin
+ # Base data dir (affects doc and others)
+ --datadir=/usr/share
+ # Make sure that the documentation is in the right place (does not work)
+ --docdir=/usr/share/doc/libmesh
+ # use relative addresses for jumps
+ --with-pic
+ # get -march flag for this system
+ --enable-march
+ # shared libraries
+ --enable-shared
+
+ # force C++11 standard (todo: check for update)
+ --enable-cxx11-required
+ # recommended by MOOSE
+ --enable-petsc-hypre-required
+ # recommended by MOOSE
+ --enable-metaphysicl-required
+ # Complex numbers
+ # make sure to compile PETSc with complex too
+ --enable-complex
+ # CURL
--enable-curl
+ # FFTW
+ --enable-fftw
+ # HDF5
--enable-hdf5
- --with-pic
+ # OpenMPI
--enable-mpi
- --enable-complex # make sure to compile PETSc with complex too
- --enable-mumps # MUMPS
- --with-mumps=/usr/include #
- --with-mumps-lib=/usr/lib #
- --enable-netcdf # NETCDF
- --with-netcdf=/usr/include #
- --with-netcdf-lib=/usr/lib #
- --with-nlopt=/usr/include # NLOPT
- --with-nlopt-lib=/usr/lib #
-
- --enable-fftw # Does this work ?
- --enable-superlu # Does this work ?
+ # METIS
+ # use PETSCs' metis
+ --with-metis=PETSc
+ # MUMPS
+ --enable-mumps
+ --with-mumps=/usr/include
+ --with-mumps-lib=/usr/lib
+ # NETCDF
+ --enable-netcdf
+ --with-netcdf=/usr/include
+ --with-netcdf-lib=/usr/lib
+ # NLOPT
+ --with-nlopt=/usr/include
+ --with-nlopt-lib=/usr/lib
+ # VTK
+ --enable-vtk-required
- --enable-shared # shared libraries
+ # infinite elements
+ --enable-ifem
--enable-unique-id # from libmesh GitHub wiki
- --enable-march # get -march flag for this system
- --enable-ifem # infinite elements
--enable-nodeconstraint # from libmesh GitHub wiki
+
+ --enable-superlu # Does this work ?
)
# Configure
- "${srcdir}/${realname}"/configure \
- --prefix=/usr \
- $(for (( i=1; i<=${#CONFOPTS[@]}; i++)); do
- echo "${CONFOPTS[$i]}";
- done)
+ local config_file="${srcdir}/${realname}"/configure
+ $config_file $(for (( i=1; i<=${#CONFOPTS[@]}; i++)); do
+ echo "${CONFOPTS[$i]}";
+ done)
# Actual build
make