summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2020-04-02 15:15:51 +0200
committerKevin Majewski2020-04-02 15:15:51 +0200
commitb73cccdbca12eec978636c450c02785545377fea (patch)
treefc548c582d182d505ad4c55305a0ee77504f8a6f
downloadaur-b73cccdbca12eec978636c450c02785545377fea.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00c1ea196863
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libmicrodns-git
+ pkgdesc = Minimal mDNS resolver library
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/videolabs/libmicrodns
+ arch = x86_64
+ license = LGPL2.1
+ depends = glibc
+ provides = libmicrodns.so
+ provides = libmicrodns
+ conflicts = libmicrodns
+ source = git+https://github.com/videolabs/libmicrodns.git
+ sha512sums = SKIP
+
+pkgname = libmicrodns-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6318847142d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=libmicrodns-git
+_pkgname=libmicrodns
+pkgver=0.1.2
+pkgrel=1
+pkgdesc='Minimal mDNS resolver library'
+url='https://github.com/videolabs/libmicrodns'
+arch=('x86_64')
+license=('LGPL2.1')
+depends=('glibc')
+provides=('libmicrodns.so' 'libmicrodns')
+conflicts=('libmicrodns')
+source=("git+https://github.com/videolabs/libmicrodns.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson "$_pkgname" build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}