summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-07-24 09:37:06 +0800
committerChocobo12017-07-24 10:10:40 +0800
commit9b526c4cff712b3a41c0477ff3ba6294d0c92fb0 (patch)
treeac0c47ceb4704cae39793594f1d046b4cc9a0827
downloadaur-9b526c4cff712b3a41c0477ff3ba6294d0c92fb0.tar.gz
newpkg: libmicrohttpd-git 0.9.55.r63.g66066283-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfee0c9987d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libmicrohttpd-git
+ pkgdesc = A small C library that make it easy to run an HTTP server as part of another application
+ pkgver = 0.9.55.r63.g66066283
+ pkgrel = 1
+ url = https://www.gnu.org/software/libmicrohttpd/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ checkdepends = curl
+ makedepends = git
+ depends = glibc
+ depends = gnutls
+ provides = libmicrohttpd
+ conflicts = libmicrohttpd
+ source = git+https://gnunet.org/git/libmicrohttpd.git
+ sha256sums = SKIP
+
+pkgname = libmicrohttpd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90f0fb978907
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libmicrohttpd-git
+pkgver=0.9.55.r63.g66066283
+pkgrel=1
+pkgdesc="A small C library that make it easy to run an HTTP server as part of another application"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/libmicrohttpd/"
+license=('LGPL')
+depends=('glibc' 'gnutls')
+makedepends=('git')
+checkdepends=('curl')
+provides=('libmicrohttpd')
+conflicts=('libmicrohttpd')
+source=("git+https://gnunet.org/git/libmicrohttpd.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libmicrohttpd"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libmicrohttpd"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libmicrohttpd"
+
+ #make check
+}
+
+package() {
+ cd "libmicrohttpd"
+
+ make DESTDIR="$pkgdir" install
+}