summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-12 21:00:48 -0500
committerVincent Grande2021-01-12 21:00:48 -0500
commit5c932cc1830645259026df94659d0dd5c643258f (patch)
tree390628907061ca0c5087e97497735f0178454f2e
downloadaur-5c932cc1830645259026df94659d0dd5c643258f.tar.gz
initial upload
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD54
-rw-r--r--cmake-man.diff11
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27230fa6b27e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = libmikmod-git
+ pkgdesc = Module player library supporting many formats, including MOD, S3M, IT and XM
+ pkgver = 3.3.11.1
+ pkgrel = 1
+ url = http://mikmod.sourceforge.net
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ makedepends = alsa-lib
+ makedepends = cmake
+ depends = glibc
+ depends = libpulse
+ depends = sh
+ provides = libmikmod.so
+ provides = libmikmod
+ conflicts = libmikmod
+ source = git://git.code.sf.net/p/mikmod/mikmod.git
+ source = cmake-man.diff
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = libmikmod-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e81ae3793384
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: David Runge <dvzrv@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=libmikmod-git
+pkgver=3.3.11.1
+pkgrel=1
+pkgdesc="Module player library supporting many formats, including MOD, S3M, IT and XM"
+url=http://mikmod.sourceforge.net
+license=(GPL2 LGPL2.1)
+arch=(x86_64)
+depends=(glibc libpulse sh)
+makedepends=(alsa-lib cmake)
+provides=(libmikmod.so libmikmod)
+conflicts=(libmikmod)
+source=(git://git.code.sf.net/p/mikmod/mikmod.git
+ cmake-man.diff)
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd libmikmod
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd libmikmod
+ patch -Np1 -i ../cmake-man.diff
+}
+
+build() {
+ # cmake ignores CPPFLAGS
+ CFLAGS+=" $CPPFLAGS"
+
+ cmake -H$libmikmod -Bbuild \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_DL=1
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+
+ install -Dt "$pkgdir/usr/share/aclocal" -m644 libmikmod/libmikmod.m4
+ install -Dt "$pkgdir/usr/share/doc/$pkgname" -m644 \
+ libmikmod/{NEWS,README,TODO} build/docs/mikmod.html
+ install -Dt "$pkgdir/usr/share/info" build/docs/mikmod.info
+ install -Dt "$pkgdir/usr/share/man/man1" build/docs/libmikmod-config.1
+}
+
+# vim: ts=2 sw=2 et:
+
diff --git a/cmake-man.diff b/cmake-man.diff
new file mode 100644
index 000000000000..9cc6b44063b7
--- /dev/null
+++ b/cmake-man.diff
@@ -0,0 +1,11 @@
+diff -u -r libmikmod-3.3.11.1/docs/CMakeLists.txt libmikmod-3.3.11.1-man/docs/CMakeLists.txt
+--- libmikmod-3.3.11.1/docs/CMakeLists.txt 2014-07-10 07:37:00.000000000 +0000
++++ libmikmod-3.3.11.1-man/docs/CMakeLists.txt 2020-01-11 18:54:48.154853499 +0000
+@@ -20,5 +20,7 @@
+ COMMENT "Creating HTML file ${html_out}"
+ VERBATIM)
+
++configure_file(libmikmod-config.1.in libmikmod-config.1 @ONLY)
++
+ add_custom_target(info ALL DEPENDS ${info_out} ${html_out})
+ ENDIF(ENABLE_DOC)