summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax2020-08-05 13:59:51 +0200
committermax2020-08-05 13:59:51 +0200
commitd320035097d36efa840718b69bcbe5dd4b0000b2 (patch)
tree45cc476873aa41918ee7d4f50844a9722cb8c345
downloadaur-d320035097d36efa840718b69bcbe5dd4b0000b2.tar.gz
Version 6.23.01
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd61d5d05c56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libminuit2
+ pkgdesc = Stand-alone Minuit2 produced from the ROOT 6 sources with no changes.
+ pkgver = 6.23.01
+ pkgrel = 1
+ url = https://github.com/GooFit/Minuit2
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ source = libminuit2-6.23.01.tar.gz::https://github.com/GooFit/Minuit2/archive/v6-23-01.tar.gz
+ sha256sums = SKIP
+
+pkgname = libminuit2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1580e46547b2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+# makepkg directories
+/src/*
+/pkg/*
+
+# Built packages
+*.tar.xz
+*.tar.zst
+
+# Downloaded sources
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da0285a31aaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: <max at swk-web.com>
+
+pkgname=libminuit2
+pkgver=6.23.01
+pkgrel=1
+pkgdesc="Stand-alone Minuit2 produced from the ROOT 6 sources with no changes."
+arch=('x86_64')
+url="https://github.com/GooFit/Minuit2"
+license=('LGPL')
+depends=()
+checkdepends=()
+makedepends=('cmake')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/GooFit/Minuit2/archive/v${pkgver//./-}.tar.gz")
+sha256sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "${srcdir}/Minuit2-${pkgver//./-}"
+
+ mkdir -p build
+}
+
+build() {
+ cd "${srcdir}/Minuit2-${pkgver//./-}/build"
+
+ # If you want you can enable these options, note that this can increase
+ # the performance but make sure that the software you link against
+ # libminuit2 is compatible with these options
+ # -Dminuit2_omp:BOOL=ON
+ # -Dminuit2_mpi:BOOL=ON
+ cmake .. -DCMAKE_INSTALL_PREFIX:PATH=/usr
+
+ # Build the actual thing
+ make -j4
+}
+
+package() {
+ # package grid libraray
+ cd "${srcdir}/Minuit2-${pkgver//./-}/build"
+ DESTDIR="${pkgdir}" make install
+}