summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarazok2020-12-10 15:02:08 +0100
committerBarazok2020-12-10 15:02:08 +0100
commiteba6920d6f4c448fcc61207428d35f10b23164c3 (patch)
treec59f35f564ad8887e96373ed91d748a8e58b51cc
downloadaur-eba6920d6f4c448fcc61207428d35f10b23164c3.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
-rw-r--r--libmlv0.install7
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02e07442c01d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libmlv0
+ pkgdesc = The MLV library is a simplified multimedia library. This library is ideal for students who are new to C programming and want to add graphic and sound effects to their programs.
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = http://www-igm.univ-mlv.fr/~boussica/mlv/api/French/html/index.html
+ install = libmlv0.install
+ arch = any
+ license = GPL
+ depends = sdl
+ depends = sdl_gfx
+ depends = sdl_mixer
+ depends = sdl_ttf
+ depends = glib2
+ depends = libxml2
+ depends = sdl_image
+ source = http://download.savannah.gnu.org/releases/mlv/mlv-2.0.2/libmlv0_2.0.2-1_amd64.deb
+ md5sums = 1c258a34b96c136aaf094772a172b874
+
+pkgname = libmlv0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..040d1d9910fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Barazok <barazok.blackrocks@gmail.com>
+pkgname=libmlv0
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="The MLV library is a simplified multimedia library. This library is ideal for students who are new to C programming and want to add graphic and sound effects to their programs."
+arch=('any')
+url="http://www-igm.univ-mlv.fr/~boussica/mlv/api/French/html/index.html"
+license=('GPL')
+groups=()
+depends=('sdl' 'sdl_gfx' 'sdl_mixer' 'sdl_ttf' 'glib2' 'libxml2' 'sdl_image')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=$pkgname.install
+changelog=
+source=("http://download.savannah.gnu.org/releases/mlv/mlv-2.0.2/libmlv0_2.0.2-1_amd64.deb")
+md5sums=("1c258a34b96c136aaf094772a172b874")
+
+package() {
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+}
diff --git a/libmlv0.install b/libmlv0.install
new file mode 100644
index 000000000000..03096856721f
--- /dev/null
+++ b/libmlv0.install
@@ -0,0 +1,7 @@
+post_install() {
+ ldconfig
+}
+
+post_remove() {
+ post_install
+}