summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarazok2020-12-10 15:02:50 +0100
committerBarazok2020-12-10 15:02:50 +0100
commita0bd5338cc21281dee032b5419fbd466b7d90669 (patch)
tree4f238f0d1a2e6412ba8b2fe1f24e14aeda456e6c
downloadaur-a0bd5338cc21281dee032b5419fbd466b7d90669.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
-rw-r--r--libmlv0-dev.install7
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39e8ddad5d8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libmlv0-dev
+ pkgdesc = The MLV library is a simplified multimedia library. This library is ideal for students who are new to C programming and want to add graphic and sound effects to their programs.
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = http://www-igm.univ-mlv.fr/~boussica/mlv/api/French/html/index.html
+ install = libmlv0-dev.install
+ arch = any
+ license = GPL
+ depends = sdl
+ depends = sdl_gfx
+ depends = sdl_mixer
+ depends = sdl_ttf
+ depends = glib2
+ depends = libxml2
+ depends = sdl_image
+ depends = libmlv0
+ source = http://download.savannah.gnu.org/releases/mlv/mlv-2.0.2/libmlv0-dev_2.0.2-1_amd64.deb
+ md5sums = 2184ed0c53c0b29764e507aa17155811
+
+pkgname = libmlv0-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3747b8cd4526
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Barazok <barazok.blackrocks@gmail.com>
+pkgname=libmlv0-dev
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="The MLV library is a simplified multimedia library. This library is ideal for students who are new to C programming and want to add graphic and sound effects to their programs."
+arch=('any')
+url="http://www-igm.univ-mlv.fr/~boussica/mlv/api/French/html/index.html"
+license=('GPL')
+groups=()
+depends=('sdl' 'sdl_gfx' 'sdl_mixer' 'sdl_ttf' 'glib2' 'libxml2' 'sdl_image' 'libmlv0')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=$pkgname.install
+changelog=
+source=("http://download.savannah.gnu.org/releases/mlv/mlv-2.0.2/libmlv0-dev_2.0.2-1_amd64.deb")
+md5sums=("2184ed0c53c0b29764e507aa17155811")
+
+package() {
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+}
diff --git a/libmlv0-dev.install b/libmlv0-dev.install
new file mode 100644
index 000000000000..03096856721f
--- /dev/null
+++ b/libmlv0-dev.install
@@ -0,0 +1,7 @@
+post_install() {
+ ldconfig
+}
+
+post_remove() {
+ post_install
+}