summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Conrad2015-10-05 00:33:54 +0200
committerStephan Conrad2015-10-05 00:33:54 +0200
commit61fcfcc2e14f48d812505f70754d196ac5c2371d (patch)
tree99f455210f3f9a4b66b2e70299d651973abed475
downloadaur-61fcfcc2e14f48d812505f70754d196ac5c2371d.tar.gz
Created modsecurity
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD53
-rw-r--r--lua_5.3.patch12
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82ff85926e74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = modsecurity
+ pkgver = 2.9.0
+ pkgrel = 1
+ arch = x86_64
+ arch = i386
+ license = ASLv2
+ depends = apache
+ depends = apr
+ depends = apr-util
+ depends = pcre
+ depends = libxml2
+ depends = lua
+ depends = curl
+ source = https://www.modsecurity.org/tarball/2.9.0/modsecurity-2.9.0.tar.gz
+ source = lua_5.3.patch
+ md5sums = ecf42d21f26338443d7111891851628c
+ md5sums = e932d70f975e6acccd0583a6e91818d1
+
+pkgname = modsecurity
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6507916c7d0e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+modsecurity-*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e37cadf61fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Stephan Conrad <stephan@conrad.pics>
+pkgname=modsecurity
+pkgver=2.9.0
+pkgrel=1
+epoch=
+pkgdesc=""
+arch=('x86_64' 'i386')
+url=""
+license=('ASLv2')
+groups=()
+depends=(
+ 'apache'
+ 'apr'
+ 'apr-util'
+ 'pcre'
+ 'libxml2'
+ 'lua'
+ 'curl'
+)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://www.modsecurity.org/tarball/2.9.0/$pkgname-$pkgver.tar.gz"
+ 'lua_5.3.patch'
+ )
+noextract=()
+md5sums=('ecf42d21f26338443d7111891851628c'
+ 'e932d70f975e6acccd0583a6e91818d1')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/lua_5.3.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --with-apxs=/usr/bin/apxs --enable-htaccess-config
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
diff --git a/lua_5.3.patch b/lua_5.3.patch
new file mode 100644
index 000000000000..5797a41bbd87
--- /dev/null
+++ b/lua_5.3.patch
@@ -0,0 +1,12 @@
+diff -rupN a/apache2/msc_lua.c b/apache2/msc_lua.c
+--- a/apache2/msc_lua.c 2015-02-12 20:08:30.000000000 +0100
++++ b/apache2/msc_lua.c 2015-10-05 00:25:20.669933315 +0200
+@@ -111,7 +111,7 @@ char *lua_compile(msc_script **script, c
+ dump.pool = pool;
+ dump.parts = apr_array_make(pool, 128, sizeof(msc_script_part *));
+
+- lua_dump(L, dump_writer, &dump);
++ lua_dump(L, dump_writer, &dump, 0);
+
+ (*script) = apr_pcalloc(pool, sizeof(msc_script));
+ (*script)->name = filename;