summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2019-05-04 00:49:29 +0200
committerlarchunix2019-05-04 00:49:29 +0200
commit641f50a6bf3da45866deeaded053adac4141c618 (patch)
treee7ecbce9ee9e7ae18cc18809c9aab5af2c93a475
parent41a25874074fab5139cce87f4dce95c31001313a (diff)
downloadaur-641f50a6bf3da45866deeaded053adac4141c618.tar.gz
Update to upstream release 2.3.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 391bf239f9ee..3a0e820af9ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libmodulemd
pkgdesc = C Library for manipulating module metadata files
- pkgver = 2.3.0
+ pkgver = 2.3.1
pkgrel = 1
url = https://github.com/fedora-modularity/libmodulemd
arch = i686
@@ -13,8 +13,8 @@ pkgbase = libmodulemd
depends = glib2
depends = libyaml
optdepends = python-gobject: for python bindings
- source = https://github.com/fedora-modularity/libmodulemd/releases/download/libmodulemd-2.3.0/modulemd-2.3.0.tar.xz
- md5sums = 7c8ec6440a1cf002f28853bb373fd2c3
+ source = https://github.com/fedora-modularity/libmodulemd/releases/download/libmodulemd-2.3.1/modulemd-2.3.1.tar.xz
+ md5sums = 061be67e72ad8d5d1dc2a624560609d4
pkgname = libmodulemd
diff --git a/PKGBUILD b/PKGBUILD
index da18d7476c92..5fc39c6a3565 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=libmodulemd
-pkgver=2.3.0
+pkgver=2.3.1
pkgrel=1
pkgdesc="C Library for manipulating module metadata files"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ depends=('glib2' 'libyaml')
makedepends=('gobject-introspection' 'gtk-doc' 'meson>=0.47' 'python-gobject')
optdepends=('python-gobject: for python bindings')
source=("$url/releases/download/$pkgname-$pkgver/${pkgname#lib}-$pkgver.tar.xz")
-md5sums=('7c8ec6440a1cf002f28853bb373fd2c3')
+md5sums=('061be67e72ad8d5d1dc2a624560609d4')
prepare() {
mv "${pkgname#lib}-$pkgver" "$pkgname-$pkgver"
@@ -19,6 +19,10 @@ build() {
cd "$pkgname-$pkgver"
arch-meson build -Ddeveloper_build=false -Dbuild_api_v1=true
ninja -C build
+
+ # Trick to be able to link binaries against either v1 or v2 API
+ sed -e '/Libs:/ s/-lmodulemd/&-2.0/' \
+ -i build/meson-private/modulemd-2.0.pc
}
check() {
@@ -30,8 +34,9 @@ package() {
cd "$pkgname-$pkgver"
DESTDIR="$pkgdir/" ninja -C build install
- # Defaults to libmodulemd API v1 until more software are ported to API v2
+ # Trick to be able to link binaries against either v1 or v2 API
ln -sf "$pkgname.so.1" "$pkgdir/usr/lib/$pkgname.so"
+ ln -sf "$pkgname.so.2" "$pkgdir/usr/lib/$pkgname-2.0.so"
install -Dp -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
install -Dp -m644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"