summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2019-03-28 21:20:07 +0100
committerlarchunix2019-03-28 21:20:07 +0100
commit7e14b36b5671cc1f0f150ffec656d43c205429e9 (patch)
tree73a2b4ad7c6588e1f912053b2c29c70ad322a40e
parent372b81e84107c7dc588d6f186819afa95c9ee0d0 (diff)
downloadaur-7e14b36b5671cc1f0f150ffec656d43c205429e9.tar.gz
Update to upstream release 2.2.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f10d1df4970f..5bacfd08071d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libmodulemd
pkgdesc = C Library for manipulating module metadata files
- pkgver = 2.2.1
+ pkgver = 2.2.2
pkgrel = 1
url = https://github.com/fedora-modularity/libmodulemd
arch = i686
@@ -8,13 +8,15 @@ pkgbase = libmodulemd
license = custom:MIT
makedepends = gobject-introspection
makedepends = gtk-doc
- makedepends = meson
+ makedepends = meson>=0.47
makedepends = python-gobject
depends = glib2
depends = libyaml
optdepends = python-gobject: for python bindings
- source = https://github.com/fedora-modularity/libmodulemd/releases/download/libmodulemd-2.2.1/modulemd-2.2.1.tar.xz
- md5sums = 597750f1814d9990e66f116f97b2ffc1
+ source = https://github.com/fedora-modularity/libmodulemd/releases/download/libmodulemd-2.2.2/modulemd-2.2.2.tar.xz
+ source = libmodulemd-2.2.2-disable-python2.patch::https://github.com/fedora-modularity/libmodulemd/pull/258.patch
+ md5sums = 5591eaa539444d43e9d61c5f7315e943
+ md5sums = cf09a032f530f9197f20174370d1d279
pkgname = libmodulemd
diff --git a/PKGBUILD b/PKGBUILD
index 63dfa26351f0..b10ba8142401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
pkgname=libmodulemd
-pkgver=2.2.1
+pkgver=2.2.2
pkgrel=1
pkgdesc="C Library for manipulating module metadata files"
arch=('i686' 'x86_64')
url="https://github.com/fedora-modularity/$pkgname"
license=('custom:MIT')
depends=('glib2' 'libyaml')
-makedepends=('gobject-introspection' 'gtk-doc' 'meson' 'python-gobject')
+makedepends=('gobject-introspection' 'gtk-doc' 'meson>=0.47' 'python-gobject')
optdepends=('python-gobject: for python bindings')
-source=("$url/releases/download/$pkgname-$pkgver/${pkgname#lib}-$pkgver.tar.xz")
-md5sums=('597750f1814d9990e66f116f97b2ffc1')
+source=("$url/releases/download/$pkgname-$pkgver/${pkgname#lib}-$pkgver.tar.xz"
+ "$pkgname-2.2.2-disable-python2.patch::$url/pull/258.patch")
+md5sums=('5591eaa539444d43e9d61c5f7315e943'
+ 'cf09a032f530f9197f20174370d1d279')
prepare() {
mv "${pkgname#lib}-$pkgver" "$pkgname-$pkgver"
+
+ cd "$pkgname-$pkgver"
+
+ # Disable python2 stuff
+ patch -p1 < "$srcdir/$pkgname-2.2.2-disable-python2.patch"
}
build() {