summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2018-12-13 20:17:11 +0100
committerlarchunix2018-12-13 20:17:11 +0100
commitcb960d74f560ceef303c5d68b022385b6bbe3746 (patch)
tree6775f55e14577e3d5d303c3cec4bee603c7e2a3b
parent3da1de12665e3a173923fbd25a8117596edf1fcf (diff)
downloadaur-cb960d74f560ceef303c5d68b022385b6bbe3746.tar.gz
Update to upstream release 2.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b26c51b99453..33a8214f29f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libmodulemd
pkgdesc = C Library for manipulating module metadata files
- pkgver = 2.0.0beta2
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/fedora-modularity/libmodulemd
arch = i686
@@ -13,8 +13,8 @@ pkgbase = libmodulemd
depends = glib2
depends = libyaml
optdepends = python-gobject: for python bindings
- source = https://github.com/fedora-modularity/libmodulemd/releases/download/libmodulemd-2.0.0beta2/modulemd-2.0.0beta2.tar.xz
- md5sums = 96a6bf20d7615f830d67fc083da560c1
+ source = https://github.com/fedora-modularity/libmodulemd/releases/download/libmodulemd-2.0.0/modulemd-2.0.0.tar.xz
+ md5sums = cce2ddc925d08c9fb9a65681f227d1c8
pkgname = libmodulemd
diff --git a/PKGBUILD b/PKGBUILD
index d11acb15390b..cb9f8f10bd08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=libmodulemd
-pkgver=2.0.0beta2
+pkgver=2.0.0
pkgrel=1
pkgdesc="C Library for manipulating module metadata files"
arch=('i686' 'x86_64')
@@ -9,10 +9,10 @@ depends=('glib2' 'libyaml')
makedepends=('gobject-introspection' 'gtk-doc' 'meson' 'python-gobject')
optdepends=('python-gobject: for python bindings')
source=("$url/releases/download/$pkgname-$pkgver/${pkgname#lib}-$pkgver.tar.xz")
-md5sums=('96a6bf20d7615f830d67fc083da560c1')
+md5sums=('cce2ddc925d08c9fb9a65681f227d1c8')
prepare() {
- mv "${pkgname#lib}-${pkgver%beta*}" "$pkgname-$pkgver"
+ mv "${pkgname#lib}-$pkgver" "$pkgname-$pkgver"
}
build() {
@@ -30,6 +30,9 @@ package() {
cd "$pkgname-$pkgver"
DESTDIR="$pkgdir/" ninja -C build install
+ # Defaults to libmodulemd API v1 until more software are ported to API v2
+ ln -sf "$pkgname.so.1" "$pkgdir/usr/lib/$pkgname.so"
+
install -Dp -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
install -Dp -m644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}