summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-09-20 11:21:33 +0800
committerChocobo12020-09-20 11:21:33 +0800
commite099978c96cb2d291d31b44fd99fac2d89cc71f3 (patch)
treeeda2a14618152496471e966ba9cd2eafcec75edc
downloadaur-e099978c96cb2d291d31b44fd99fac2d89cc71f3.tar.gz
newpkg: libmpc-git 1.2.0.r11.g7afb2a7-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa201ba3cd97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libmpc-git
+ pkgdesc = C library for the arithmetic of complex numbers
+ pkgver = 1.2.0.r11.g7afb2a7
+ pkgrel = 1
+ url = http://www.multiprecision.org/mpc/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ depends = mpfr
+ provides = libmpc
+ conflicts = libmpc
+ options = staticlibs
+ source = git+https://gitlab.inria.fr/mpc/mpc.git
+ sha256sums = SKIP
+
+pkgname = libmpc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d84b95e7b8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libmpc-git
+pkgver=1.2.0.r11.g7afb2a7
+pkgrel=1
+pkgdesc="C library for the arithmetic of complex numbers"
+arch=('i686' 'x86_64')
+url="http://www.multiprecision.org/mpc/"
+license=('LGPL')
+depends=('glibc' 'mpfr')
+makedepends=('git')
+provides=('libmpc')
+conflicts=('libmpc')
+options=('staticlibs')
+source=("git+https://gitlab.inria.fr/mpc/mpc.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "mpc"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "mpc"
+
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "mpc"
+
+ make check
+}
+
+package() {
+ cd "mpc"
+
+ make DESTDIR="$pkgdir" install
+
+ mv "$pkgdir/usr/share/info"/{mpc,libmpc}.info
+}