summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugen Zagorodniy2020-01-12 20:17:16 +0200
committerEugen Zagorodniy2020-01-12 20:17:16 +0200
commit205e09373353cbae5a33e15b839ece16cde5e36f (patch)
tree0f8d04a6c95e48013134cec510129f6196fddc4b
downloadaur-205e09373353cbae5a33e15b839ece16cde5e36f.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a4ad723a307
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = libmsp430
+ pkgdesc = MSP Debug Stack library (e.g. for using mspdebug with tilib driver)
+ pkgver = 3_14_0_000
+ pkgrel = 1
+ url = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPDS/latest/index_FDS.html
+ arch = x86_64
+ license = custom
+ source = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPDS/latest/exports/MSP430_DLL_Developer_Package_Rev_3_14_0_000.zip
+ sha256sums = 2f4cbafe1c844618245e60cf0e63ea1773763b092834dfb57c8728d6de73c9be
+
+pkgname = libmsp430
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d26a0ad18d2f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+/*.zip
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1589f089b905
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Eugen Zagorodniy <https://github.com/ezag>
+
+pkgname=libmsp430
+pkgver=3_14_0_000
+pkgrel=1
+pkgdesc='MSP Debug Stack library (e.g. for using mspdebug with tilib driver)'
+
+arch=('x86_64')
+url="http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPDS/latest/index_FDS.html"
+license=('custom')
+
+source=(
+ "http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPDS/latest/exports/MSP430_DLL_Developer_Package_Rev_$pkgver.zip"
+)
+sha256sums=('2f4cbafe1c844618245e60cf0e63ea1773763b092834dfb57c8728d6de73c9be')
+
+package() {
+ install -D "$srcdir/${pkgname}_64.so" "$pkgdir/usr/lib/${pkgname}.so"
+}