summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-11-16 12:49:23 +0100
committerAlbert Graef2015-11-16 12:49:23 +0100
commit350ab20c6cc52c34a52ce093877586f8cf04808b (patch)
tree6b6feecd3834a5cab69f908c427d0aeb06feb693
downloadaur-350ab20c6cc52c34a52ce093877586f8cf04808b.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6dc81c8c5fdf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libmusicxml-git
+ pkgdesc = library and tools for the MusicXML format (git version)
+ pkgver = 34.68feb19
+ pkgrel = 1
+ url = https://github.com/dfober/libmusicxml
+ arch = x86_64
+ arch = i686
+ license = LGPL
+ makedepends = cmake
+ provides = libmusicxml
+ conflicts = libmusicxml
+ source = libmusicxml-git::git+https://github.com/dfober/libmusicxml
+ md5sums = SKIP
+
+pkgname = libmusicxml-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a068146310b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: aggraef@gmail.com
+pkgname=libmusicxml-git
+pkgver=34.68feb19
+pkgrel=1
+pkgdesc="library and tools for the MusicXML format (git version)"
+arch=('x86_64' 'i686')
+url="https://github.com/dfober/libmusicxml"
+license=('LGPL')
+makedepends=('cmake')
+provides=('libmusicxml')
+conflicts=('libmusicxml')
+source=("$pkgname::git+https://github.com/dfober/libmusicxml")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$pkgname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$srcdir/$pkgname/cmake"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -G "Unix Makefiles"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/cmake"
+ make install DESTDIR="$pkgdir"
+}