summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2019-01-06 18:40:24 +0100
committerMaxime Gauduin2019-01-06 18:40:24 +0100
commitcf791069ba42b681d5a47ac1ad0c40bf046eaf88 (patch)
treeb74cd523dafa057f97e4bbe24356382417576bb1
downloadaur-cf791069ba42b681d5a47ac1ad0c40bf046eaf88.tar.gz
Initial commit
-rw-r--r--.SRCINFO63
-rw-r--r--PKGBUILD96
2 files changed, 159 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d02f66690621
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,63 @@
+# Generated by mksrcinfo v8
+# Sun Jan 6 17:40:24 UTC 2019
+pkgbase = libmutter2
+ pkgdesc = A window manager library for GNOME
+ pkgver = 3.28.3
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/mutter
+ arch = x86_64
+ license = GPL
+ makedepends = egl-wayland
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = intltool
+ depends = atk
+ depends = cairo
+ depends = dconf
+ depends = fontconfig
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gnome-desktop
+ depends = gnome-settings-daemon
+ depends = gobject-introspection-runtime
+ depends = gtk3
+ depends = json-glib
+ depends = libcanberra
+ depends = libdrm
+ depends = libfreetype.so
+ depends = libgl
+ depends = libgudev-1.0.so
+ depends = libice
+ depends = libinput
+ depends = libsm
+ depends = libsystemd.so
+ depends = libudev.so
+ depends = libvorbisfile.so
+ depends = libwacom
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxinerama
+ depends = libxkbcommon
+ depends = libxkbcommon-x11
+ depends = libxkbfile
+ depends = libxrandr
+ depends = libxrender
+ depends = libxtst
+ depends = mesa
+ depends = pango
+ depends = startup-notification
+ depends = tdb
+ depends = upower
+ depends = wayland
+ depends = zenity
+ source = git+https://gitlab.gnome.org/GNOME/mutter.git#tag=3.28.3
+ sha256sums = SKIP
+
+pkgname = libmutter2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ad40221f6df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,96 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Michael Kanis <mkanis@gmx.de>
+
+pkgname=libmutter2
+pkgver=3.28.3
+pkgrel=1
+pkgdesc='A window manager library for GNOME'
+url='https://gitlab.gnome.org/GNOME/mutter'
+arch=(x86_64)
+license=(GPL)
+depends=(
+ atk
+ cairo
+ dconf
+ fontconfig
+ gdk-pixbuf2
+ glib2
+ gnome-desktop
+ gnome-settings-daemon
+ gobject-introspection-runtime
+ gtk3
+ json-glib
+ libcanberra
+ libdrm
+ libfreetype.so
+ libgl
+ libgudev-1.0.so
+ libice
+ libinput
+ libsm
+ libsystemd.so
+ libudev.so
+ libvorbisfile.so
+ libwacom
+ libx11
+ libxcb
+ libxcomposite
+ libxcursor
+ libxdamage
+ libxext
+ libxfixes
+ libxi
+ libxinerama
+ libxkbcommon
+ libxkbcommon-x11
+ libxkbfile
+ libxrandr
+ libxrender
+ libxtst
+ mesa
+ pango
+ startup-notification
+ tdb
+ upower
+ wayland
+ zenity
+)
+makedepends=(
+ egl-wayland
+ git
+ gobject-introspection
+ intltool
+)
+source=(git+https://gitlab.gnome.org/GNOME/mutter.git#tag=${pkgver})
+sha256sums=(SKIP)
+
+prepare() {
+ cd mutter
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd mutter
+
+ ./configure \
+ --prefix='/usr' \
+ --includedir='/usr/include/mutter-2' \
+ --disable-gtk-doc \
+ --disable-schemas-compile \
+ --disable-remote-desktop \
+ --disable-static \
+ --enable-compile-warnings='minimum' \
+ --enable-egl-device
+
+ make
+}
+
+package() {
+ make DESTDIR="${pkgdir}" -C mutter install
+ rm -rf ${pkgdir}/usr/{bin,lib/mutter/plugins/default.so,libexec,share}
+}
+
+# vim: ts=2 sw=2 et: