summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobozzz2015-06-11 19:00:56 +0200
committerChocobozzz2015-06-11 19:00:56 +0200
commit89da02cd8a84359d48445c32c15849549a188efa (patch)
tree9a884a7c972e5cf6a426a79e3d489d7780752ea1
downloadaur-89da02cd8a84359d48445c32c15849549a188efa.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--include_suffix.patch11
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cd22c11280a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libmygpo-qt5-git
+ pkgdesc = A C++/Qt client library for gpodder.net. Git and Qt5 version.
+ pkgver = 1.0.8.2.g7946293
+ pkgrel = 1
+ url = http://wiki.gpodder.org/wiki/Libmygpo-qt
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = cmake
+ makedepends = doxygen
+ depends = qt5-base
+ provides = libmygpo-qt5
+ conflicts = libmygpo-qt5
+ source = git+https://github.com/gpodder/libmygpo-qt.git
+ source = include_suffix.patch
+ sha256sums = SKIP
+ sha256sums = 7994f3c29086268b8138e7ac0c0d1a99acfa55e07a7695507f314903b890f79d
+
+pkgname = libmygpo-qt5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc7a30257f74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Florian Bigard <florian.bigard@gmail.com>
+# Thanks to Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=libmygpo-qt5-git
+pkgver=1.0.8.2.g7946293
+pkgrel=1
+pkgdesc="A C++/Qt client library for gpodder.net. Git and Qt5 version."
+arch=('i686' 'x86_64')
+url="http://wiki.gpodder.org/wiki/Libmygpo-qt"
+license=('LGPL2.1')
+depends=('qt5-base')
+makedepends=('cmake' 'doxygen')
+source=("git+https://github.com/gpodder/libmygpo-qt.git" "include_suffix.patch")
+sha256sums=('SKIP' '7994f3c29086268b8138e7ac0c0d1a99acfa55e07a7695507f314903b890f79d')
+provides=('libmygpo-qt5')
+conflicts=('libmygpo-qt5')
+
+pkgver() {
+ cd libmygpo-qt
+ git describe | sed 's/^v//;s/-/./g;s/_/./g;'
+}
+
+prepare() {
+ cd libmygpo-qt
+ patch -Np0 -i "../include_suffix.patch"
+ cd ../
+ mkdir build
+}
+
+build() {
+ cd build
+ cmake "../libmygpo-qt" \
+ -DBUILD_WITH_QT4=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package(){
+ cd build
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/include_suffix.patch b/include_suffix.patch
new file mode 100644
index 000000000000..8f9ea7d2250e
--- /dev/null
+++ b/include_suffix.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt 2015-06-04 15:08:42.414256487 +0200
++++ CMakeLists.txt.patch 2015-06-04 15:08:14.510491630 +0200
+@@ -98,7 +98,7 @@
+ set(LIB_SUFFIX "" CACHE STRING "The directories where to install libraries to")
+ set(LIB_INSTALL_DIR lib${LIB_SUFFIX} )
+ set(LIB_DIR_PKGCONF "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
+-set(INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include/mygpo-qt" CACHE PATH "The directory the headers are installed in")
++set(INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include/mygpo-qt${MYGPO_QT_VERSION_SUFFIX}" CACHE PATH "The directory the headers are installed in")
+ set(CMAKECONFIG_INSTALL_DIR ${LIB_INSTALL_DIR}/cmake/mygpo-qt )
+
+ if( APPLE )