summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2015-12-27 10:21:08 +0800
committerIru Cai2015-12-27 10:45:28 +0800
commit339afece00742f0bc72a41285c82fb8e9abf207f (patch)
tree734482d6df80bc1a099dc257eaa6098a887448f4
downloadaur-339afece00742f0bc72a41285c82fb8e9abf207f.tar.gz
libmypaint initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a08cc6f720af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 02:45:10 UTC 2015
+pkgbase = libmypaint-git
+ pkgdesc = a library for making brushstrokes which is used by MyPaint and other projects
+ pkgver = 1.1.r545
+ pkgrel = 1
+ url = http://mypaint.org/
+ arch = i686
+ arch = x86_64
+ license = ISC
+ makedepends = scons
+ makedepends = python
+ depends = gegl
+ depends = babl
+ depends = json-c
+ source = git+https://github.com/mypaint/libmypaint.git
+ md5sums = SKIP
+
+pkgname = libmypaint-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..355fb1122e90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Iru Cai <mytbk920423@gmail.com>
+# build for gimp-git, with gegl support
+
+pkgname=libmypaint-git
+pkgver=1.1.r545
+pkgrel=1
+pkgdesc="a library for making brushstrokes which is used by MyPaint and other projects"
+arch=('i686' 'x86_64')
+url="http://mypaint.org/"
+license=('ISC')
+depends=('gegl' 'babl' 'json-c')
+makedepends=('scons' 'python')
+source=('git+https://github.com/mypaint/libmypaint.git')
+md5sums=('SKIP')
+
+build() {
+ true
+}
+
+package() {
+ cd "$srcdir/libmypaint"
+
+ scons prefix=/usr enable_gegl=true use_sharedlib=yes \
+ --install-sandbox="$pkgdir" "$pkgdir"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ cp COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+pkgver() {
+ cd "$srcdir/$libmypaint"
+
+ ver=1.1 # use the brushlib_version in SConscript
+ count=$(git rev-list --count HEAD)
+# commit=$(git rev-parse --short HEAD)
+ echo $ver.r$count
+}
+
+# vim:set ts=2 sw=2 et: