summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Westra2017-07-06 16:24:32 -0700
committerAlbert Westra2017-07-06 16:24:32 -0700
commit428c62594b9884b9f5315cbf522dc2c4d3296e5f (patch)
treec5abe2fada0524a55acc6b1f6b08445320a3cc70
parent27ab8f5935eb378b46c0333b0779b3c0cab16491 (diff)
downloadaur-428c62594b9884b9f5315cbf522dc2c4d3296e5f.tar.gz
Remove Gegl Dependency and Fixed Version
Removed gegl dependency temporarlity untill it can build again. Also corrected the pkgversion of libmypaint and have it follow MyPaint Major.Minor versioning scheme.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 264c244c6714..5b5473f5c41b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Jun 24 03:44:13 UTC 2017
pkgbase = libmypaint-git
- pkgdesc = a library for making brushstrokes which is used by MyPaint and other projects, with GEGL support
- pkgver = 1.3.0.33.ge5becee
+ pkgdesc = A library for making brushstrokes which is used by MyPaint and other projects.
+ pkgver = 2.0.0.alpha+git.1672d09
pkgrel = 1
url = http://mypaint.org/
arch = i686
@@ -13,8 +11,7 @@ pkgbase = libmypaint-git
makedepends = python
depends = gobject-introspection
depends = json-c
- depends = gegl
- provides = libmypaint=1.3.0.33.ge5becee
+ provides = libmypaint=2.0.0.alpha+git.1672d09
conflicts = libmypaint
source = git+https://github.com/mypaint/libmypaint.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d48c39ad2d7c..ae7a50193bd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
+# Maintainer: Albert Westra <odyssyewestra@gmail.com>
# Maintainer: Iru Cai <mytbk920423@gmail.com>
+_basever=2.0.0.alpha
pkgname=libmypaint-git
-pkgver=1.3.0.33.ge5becee
+pkgver=2.0.0.alpha+git.1672d09
pkgrel=1
-pkgdesc="a library for making brushstrokes which is used by MyPaint and other projects, with GEGL support"
+pkgdesc="A library for making brushstrokes which is used by MyPaint and other projects."
arch=('i686' 'x86_64')
url="http://mypaint.org/"
license=('ISC')
-depends=('gobject-introspection' 'json-c' 'gegl')
+depends=('gobject-introspection' 'json-c')
makedepends=('git' 'intltool' 'python')
provides=("libmypaint=${pkgver}")
conflicts=('libmypaint')
@@ -18,7 +20,7 @@ build() {
cd "$srcdir/libmypaint"
./autogen.sh
- ./configure --prefix=/usr --enable-gegl
+ ./configure --prefix=/usr
make
}
@@ -32,7 +34,7 @@ package() {
pkgver() {
cd "$srcdir/libmypaint"
- git describe --tags | sed 's/^v//g;s/-/./g'
+ printf "${_basever}+git.%s" "$(git rev-parse --short HEAD)" | sed 's/^v//g;s/-/./g'
}
# vim:set ts=2 sw=2 et: