summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2016-05-18 10:40:54 +0800
committerIru Cai2016-05-18 10:40:54 +0800
commit49e31030aae75b6f662994516ff278731031884a (patch)
tree8f8b2da79d7106b1014002a0e6ed4cc5d9ed37e4
parentffbbe088193152121164de33ee24bc5281138d3f (diff)
downloadaur-49e31030aae75b6f662994516ff278731031884a.tar.gz
update, use autotools instead of scons
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22989dd7633a..abc3a23447ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Thu Apr 28 00:17:13 UTC 2016
+# Wed May 18 02:40:49 UTC 2016
pkgbase = libmypaint-git
- pkgdesc = a library for making brushstrokes which is used by MyPaint and other projects
- pkgver = 1.1.r591
+ pkgdesc = a library for making brushstrokes which is used by MyPaint and other projects, with GEGL support
+ pkgver = 1.1.r640
pkgrel = 1
url = http://mypaint.org/
arch = i686
arch = x86_64
license = ISC
- makedepends = scons
+ makedepends = intltool
makedepends = python
- depends = gegl
- depends = babl
+ depends = gobject-introspection
depends = json-c
+ depends = gegl
source = git+https://github.com/mypaint/libmypaint.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f824cec8ebb0..95501ba761b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Iru Cai <mytbk920423@gmail.com>
-# build for gimp-git, with gegl support
pkgname=libmypaint-git
-pkgver=1.1.r591
+pkgver=1.1.r640
pkgrel=1
-pkgdesc="a library for making brushstrokes which is used by MyPaint and other projects"
+pkgdesc="a library for making brushstrokes which is used by MyPaint and other projects, with GEGL support"
arch=('i686' 'x86_64')
url="http://mypaint.org/"
license=('ISC')
-depends=('gegl' 'babl' 'json-c')
-makedepends=('scons' 'python')
+depends=('gobject-introspection' 'json-c' 'gegl')
+makedepends=('intltool' 'python')
source=('git+https://github.com/mypaint/libmypaint.git')
md5sums=('SKIP')
build() {
- true
+ cd "$srcdir/libmypaint"
+
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-gegl
+ make
}
package() {
cd "$srcdir/libmypaint"
- scons prefix=/usr enable_gegl=true use_sharedlib=yes \
- --install-sandbox="$pkgdir" "$pkgdir"
-
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- cp COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
pkgver() {