summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-06-30 11:48:28 -0300
committerDaniel Bermond2017-06-30 11:48:28 -0300
commit0a57e5699526af85088586d94f1947ae95484b68 (patch)
tree49bfcb4dc40555b2325d74dbbe02808c47f8fcf4
parent630c4f2ce11cdfedaef48372a0fe9c3bf3ff2116 (diff)
downloadaur-0a57e5699526af85088586d94f1947ae95484b68.tar.gz
Cleanup and cosmetic changings
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7eb8b60b1623..ac874dcd8d7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jun 10 18:00:26 UTC 2017
+# Fri Jun 30 14:48:01 UTC 2017
pkgbase = libmysofa-git
pkgdesc = C library to read HRTFs if they are stored in the AES69-2015 SOFA format (git version)
- pkgver = 0.4.r52.g58a1128
+ pkgver = 0.5.r1.gb915602
pkgrel = 1
url = https://hoene.github.io/libmysofa/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 14f554190b78..ebd4342b53b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=libmysofa-git
-pkgver=0.4.r52.g58a1128
+pkgver=0.5.r1.gb915602
pkgrel=1
pkgdesc='C library to read HRTFs if they are stored in the AES69-2015 SOFA format (git version)'
arch=('i686' 'x86_64')
@@ -18,17 +18,18 @@ pkgver() {
cd "$pkgname"
# git, tags available
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;s/,//'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
cd "${pkgname}/build"
cmake \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- -DBUILD_TESTS:BOOL=OFF \
- -DCMAKE_BUILD_TYPE:STRING=Release \
- -DCMAKE_COLOR_MAKEFILE:BOOL=ON \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DBUILD_SHARED_LIBS:BOOL='ON' \
+ -DBUILD_TESTS:BOOL='OFF' \
+ -DCMAKE_BUILD_TYPE:STRING='Release' \
+ -DCMAKE_COLOR_MAKEFILE:BOOL='ON' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -Wno-dev \
..
make all
}