summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-08-30 19:13:11 +0000
committerDaniel Bermond2018-08-30 19:13:11 +0000
commit6bd85e2e209984b3308c4645c5de3ba2b4421682 (patch)
tree52766b131d8451fded399a9cf9176060e8844201
parent122816b5fc1fcde6056334d5b025da2dfbd9b6c1 (diff)
downloadaur-6bd85e2e209984b3308c4645c5de3ba2b4421682.tar.gz
Fix libdir
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b81c6a5d586..e01d48868755 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Wed Aug 9 17:19:46 UTC 2017
pkgbase = libmysofa-git
pkgdesc = C library to read HRTFs if they are stored in the AES69-2015 SOFA format (git version)
- pkgver = 0.6.r3.g00c6e62
- pkgrel = 2
+ pkgver = 0.6.r56.g5e1fc5b
+ pkgrel = 1
url = https://hoene.github.io/libmysofa/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 71ed088c47c9..26b054c3f7b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=libmysofa-git
-pkgver=0.6.r3.g00c6e62
-pkgrel=2
+pkgver=0.6.r56.g5e1fc5b
+pkgrel=1
pkgdesc='C library to read HRTFs if they are stored in the AES69-2015 SOFA format (git version)'
arch=('i686' 'x86_64')
url='https://hoene.github.io/libmysofa/'
@@ -23,14 +23,15 @@ pkgver() {
build() {
cd "${pkgname}/build"
+
cmake \
-DBUILD_SHARED_LIBS:BOOL='ON' \
-DBUILD_TESTS:BOOL='OFF' \
- -DCMAKE_BUILD_TYPE:STRING='Release' \
- -DCMAKE_COLOR_MAKEFILE:BOOL='ON' \
+ -DCMAKE_INSTALL_LIBDIR:PATH='lib' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-Wno-dev \
..
+
make all
}
@@ -39,5 +40,5 @@ package() {
make DESTDIR="$pkgdir" install
cd "${srcdir}/${pkgname}"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}