summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-07-14 15:30:38 +0000
committerDaniel Bermond2019-07-14 15:30:38 +0000
commite091e22b8056060f2cc6d7242f39d67abc610c5b (patch)
tree894024707f7448c480ea27c8c48e547a6b201a91
parentdde76a6fd9b327007bb41b7dfc6306cb12cc269f (diff)
downloadaur-e091e22b8056060f2cc6d7242f39d67abc610c5b.tar.gz
Drop i686 support
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3608c79e440b..a92f11fdd47f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = libmysofa-git
pkgdesc = C library to read HRTFs if they are stored in the AES69-2015 SOFA format (git version)
- pkgver = 0.7.r0.g2ed84bb
+ pkgver = 0.7.r10.g3dba53f
pkgrel = 1
url = https://hoene.github.io/libmysofa/
- arch = i686
arch = x86_64
license = BSD
checkdepends = nodejs
diff --git a/PKGBUILD b/PKGBUILD
index 9427e1151e95..355285364fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=libmysofa-git
-_srcname=libmysofa
-pkgver=0.7.r0.g2ed84bb
+pkgver=0.7.r10.g3dba53f
pkgrel=1
pkgdesc='C library to read HRTFs if they are stored in the AES69-2015 SOFA format (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://hoene.github.io/libmysofa/'
license=('BSD')
depends=('zlib')
@@ -17,14 +16,14 @@ source=('git+https://github.com/hoene/libmysofa.git')
sha256sums=('SKIP')
pkgver() {
- cd "$_srcname"
+ cd libmysofa
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "${_srcname}/build"
+ cd libmysofa/build
cmake \
-DBUILD_TESTS:BOOL='ON' \
@@ -37,16 +36,16 @@ build() {
}
check() {
- cd "${_srcname}/build"
+ cd libmysofa/build
make test
}
package() {
- cd "${_srcname}/build"
+ cd libmysofa/build
make DESTDIR="$pkgdir" install
- cd "${srcdir}/${_srcname}"
+ cd "${srcdir}/libmysofa"
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}