summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarry Jeffery2016-07-25 15:18:20 +0100
committerHarry Jeffery2016-07-25 15:18:20 +0100
commitc9559ea0949bcb12d6d7f2ecff9be88ef54450b5 (patch)
treeec7b0adb299ff50caf51cf5e533987e0cb649acb
parent1e54a658ce937006a7f5fcb9e9e2f0d362c1e98f (diff)
downloadaur-c9559ea0949bcb12d6d7f2ecff9be88ef54450b5.tar.gz
Update to v4.4.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e02e9241b885..f632a4d419db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Jul 25 12:12:39 UTC 2016
pkgbase = libnexus
pkgdesc = libnexus provides functionality for loading/saving the nexus file format for scientific data
- pkgver = 4.3.1
- pkgrel = 3
+ pkgver = 4.4.2
+ pkgrel = 1
url = http://www.nexusformat.org/
arch = x86_64
arch = i686
license = GPL
depends = hdf5-cpp-fortran
optdepends = hdf4: hdf4 file format support
- source = http://download.nexusformat.org/kits/4.3.1/nexus-4.3.1.tar.gz
- sha1sums = ed75a442acad8bc14745df42822286fb735ed526
+ source = libnexus::git://github.com/nexusformat/code.git#tag=v4.4.2
+ sha1sums = SKIP
pkgname = libnexus
diff --git a/PKGBUILD b/PKGBUILD
index fa7c7251d6a8..a9cd80c4c5a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
# Maintainer: Harry Jeffery <harry|@|exec64|.|co|.|uk>
pkgname=libnexus
-pkgver=4.3.1
-pkgrel=3
+pkgver=4.4.2
+pkgrel=1
pkgdesc="libnexus provides functionality for loading/saving the nexus file format for scientific data"
url="http://www.nexusformat.org/"
arch=('x86_64' 'i686')
license=('GPL')
depends=('hdf5-cpp-fortran')
optdepends=('hdf4: hdf4 file format support')
-source=("http://download.nexusformat.org/kits/${pkgver}/nexus-${pkgver}.tar.gz")
-sha1sums=('ed75a442acad8bc14745df42822286fb735ed526')
+source=("$pkgname::git://github.com/nexusformat/code.git#tag=v${pkgver}")
+sha1sums=('SKIP')
build() {
- cd "${srcdir}/nexus-${pkgver}"
- ./configure --prefix="${pkgdir}/usr"
+ mkdir -p "${srcdir}/build"
+ cd "${srcdir}/build"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_CXX=ON \
+ "${srcdir}/libnexus"
make
}
package() {
- cd "${srcdir}/nexus-${pkgver}"
- make install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
}
# vim:set ts=2 sw=2 et: