summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2017-10-12 21:27:08 +0200
committerÉtienne Deparis2017-10-12 21:27:08 +0200
commit955e3242d4e6e7ae5f4d65d4a4f875665ccacc17 (patch)
treee890bd920a931c2f7399c2973232324cff5c83e0
downloadaur-955e3242d4e6e7ae5f4d65d4a4f875665ccacc17.tar.gz
Create package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd9c706466bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 5.0.2
+# Thu Oct 12 19:26:46 UTC 2017
+pkgbase = libnitrokey
+ pkgdesc = Communicate with Nitrokey stick devices in a clean and easy manner
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://www.nitrokey.com
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = qt5-tools
+ makedepends = libcatch-cpp-headers
+ depends = hidapi
+ source = https://github.com/Nitrokey/libnitrokey/archive/v3.0.tar.gz
+ sha256sums = 9bc47efbd2f97af859d7bb4d07556f7f83e58f6de63fdba92d75b999b578ec15
+
+pkgname = libnitrokey
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca6eb642272f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+
+pkgname=libnitrokey
+pkgver=3.0
+pkgrel=1
+pkgdesc="Communicate with Nitrokey stick devices in a clean and easy manner"
+arch=('i686' 'x86_64')
+url="https://www.nitrokey.com"
+license=('LGPL3')
+depends=(hidapi)
+makedepends=('cmake' 'qt5-tools' 'libcatch-cpp-headers')
+source=("https://github.com/Nitrokey/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('9bc47efbd2f97af859d7bb4d07556f7f83e58f6de63fdba92d75b999b578ec15')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+
+ cmake .. \
+ -DLIBNITROKEY_STATIC=OFF \
+ -DCOMPILE_TESTS=OFF \
+ -DUSE_CLANG=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir" install
+ install -d -m755 "$pkgdir/usr/lib/$pkgname"
+
+ cd ..
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "${pkgdir}/usr/"
+ mv include $pkgdir/usr/lib/${pkgname}/
+
+ mv lib64/libnitrokey.so lib/libnitrokey/
+ mv lib64/libnitrokey.so.3 lib/libnitrokey/
+ mv lib64/libnitrokey.so.$pkgver.0 lib/libnitrokey/
+ mv lib64/libnitrokey-log.so lib/libnitrokey/
+ mv lib64/libnitrokey-log.so.3 lib/libnitrokey/
+ mv lib64/libnitrokey-log.so.$pkgver.0 lib/libnitrokey/
+ rmdir lib64
+}