summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2018-02-11 19:26:06 +0100
committerÉtienne Deparis2018-02-11 19:26:06 +0100
commitfebfce306dffae925462a329ffc8979f6f8f3419 (patch)
tree4249abe6544af5e2745706a553ebbfc52c945190
parentd7e0e1dd268e162e851978dcb0ede4b2f98071b3 (diff)
downloadaur-febfce306dffae925462a329ffc8979f6f8f3419.tar.gz
Use CMAKE variables instead of bash quick fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 5 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 838e8d0a3202..751ead6c7deb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 5.0.2
-# Sun Feb 11 18:06:56 UTC 2018
+# Sun Feb 11 18:25:29 UTC 2018
pkgbase = libnitrokey
pkgdesc = Communicate with Nitrokey stick devices in a clean and easy manner
pkgver = 3.2
- pkgrel = 4
+ pkgrel = 5
url = https://www.nitrokey.com
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 41023433f520..16620f9ce7d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libnitrokey
pkgver=3.2
-pkgrel=4
+pkgrel=5
pkgdesc="Communicate with Nitrokey stick devices in a clean and easy manner"
arch=('i686' 'x86_64')
url="https://www.nitrokey.com"
@@ -15,12 +15,6 @@ sha256sums=('b4ebffcf2143fb2cf535200a1f77ac123d50d87747e40ff8587f3fad2f2cb0fa')
prepare() {
cd "$srcdir/$pkgname-$pkgver/"
mkdir -p build
-
- # This modify the template file, which will serve to generate the
- # /usr/lib/pkgconfig/libnitrokey-1.pc final file. Without this line,
- # the pkgconfig file will keep a reference to /usr/lib64
- sed -i 's|^libdir=@CMAKE_INSTALL_FULL_LIBDIR@$|libdir=/usr/lib|' \
- libnitrokey.pc.in
}
build() {
@@ -29,7 +23,8 @@ build() {
cmake .. \
-DBUILD_SHARED_LIBS=ON \
-DCOMPILE_TESTS=OFF \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
make
}
@@ -39,7 +34,4 @@ package() {
cd ..
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- cd "${pkgdir}/usr/"
- mv lib64 lib
}