summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2017-10-12 22:08:18 +0200
committerÉtienne Deparis2017-10-12 22:08:18 +0200
commit66fae90cd7afd3d5a0e2f22f803509d26078120d (patch)
treef1436b5fa573bb49b9d1c854fe72770f9d43b3ea
parenta6b1aa997a3eeb63229ae3142e7b1e870abfd12a (diff)
downloadaur-66fae90cd7afd3d5a0e2f22f803509d26078120d.tar.gz
Fix namcap errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fc06fd44eed..c26c0c839802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
# Generated by makepkg 5.0.2
-# Tue Sep 19 19:48:12 UTC 2017
+# Thu Oct 12 20:07:53 UTC 2017
pkgbase = libnitrokey-git
pkgdesc = Communicate with Nitrokey stick devices in a clean and easy manner
- pkgver = 3.0r515.8f7435e
- pkgrel = 4
+ pkgver = 3.1r587.91f88b1
+ pkgrel = 1
url = https://www.nitrokey.com
arch = i686
arch = x86_64
license = LGPL3
makedepends = cmake
makedepends = qt5-tools
- depends = libusb
depends = hidapi
provides = libnitrokey
conflicts = libnitrokey
diff --git a/PKGBUILD b/PKGBUILD
index 7c36776ff2d1..c84358a77597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=libnitrokey-git
_gitname=libnitrokey
-pkgver=3.0r515.8f7435e
-pkgrel=4
+pkgver=3.1r587.91f88b1
+pkgrel=1
pkgdesc="Communicate with Nitrokey stick devices in a clean and easy manner"
arch=('i686' 'x86_64')
url="https://www.nitrokey.com"
license=('LGPL3')
-depends=(libusb hidapi)
+depends=(hidapi)
makedepends=('cmake' 'qt5-tools')
provides=('libnitrokey')
conflicts=('libnitrokey')
@@ -17,7 +17,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${_gitname}/"
- curver=$(sed -n 's/^SET(PROJECT_VERSION "\(.*\)-alpha")$/\1/p' CMakeLists.txt)
+ curver=$(sed -n 's/^SET(PROJECT_VERSION "\(.*\)")$/\1/p' CMakeLists.txt)
printf "%sr%s.%s" "$curver" "$(git rev-list --count HEAD)" \
"$(git rev-parse --short HEAD)"
}
@@ -41,11 +41,10 @@ build() {
package() {
cd "$srcdir/${_gitname}/build"
make DESTDIR="$pkgdir" install
- install -D -m755 libnitrokey-log.so "$pkgdir/usr/lib/libnitrokey-log.so"
cd ..
- install -d -m755 $pkgdir/usr/lib/${_gitname}
- cp -R include $pkgdir/usr/lib/${_gitname}/
-
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
+
+ cd "${pkgdir}/usr/"
+ mv lib64 lib
}