summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPitBall2015-07-13 14:21:38 +0200
committerPitBall2015-07-13 14:21:38 +0200
commitf616e0c83e6cee497292672cddd372e9f2563ce1 (patch)
tree33290ac5730569342a6b46f091d5259adc15b673
downloadaur-f616e0c83e6cee497292672cddd372e9f2563ce1.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e077fd3a6748
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libnotify-gtk2
+ pkgdesc = Desktop notification library
+ pkgver = 0.7.6
+ pkgrel = 1
+ url = http://library.gnome.org/devel/notification-spec/
+ arch = x86_64
+ license = LGPL
+ depends = gdk-pixbuf2
+ depends = gtk2
+ provides = libnotify=0.7.6
+ conflicts = libnotify
+ conflicts = libnotify-git
+ conflicts = libnotify-id
+ conflicts = libnotify-id-git
+ replaces = libnotify
+ source = http://ftp.gnome.org/pub/GNOME/sources/libnotify/0.7/libnotify-0.7.6.tar.xz
+ sha256sums = 0ef61ca400d30e28217979bfa0e73a7406b19c32dd76150654ec5b2bdf47d837
+
+pkgname = libnotify-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43e5274cca59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: PitBall
+
+pkgname=libnotify-gtk2
+pkgver=0.7.6
+pkgrel=1
+pkgdesc="Desktop notification library"
+arch=('x86_64')
+url="http://library.gnome.org/devel/notification-spec/"
+license=('LGPL')
+depends=('gdk-pixbuf2' 'gtk2')
+conflicts=('libnotify' 'libnotify-git' 'libnotify-id' 'libnotify-id-git')
+provides=("libnotify=$pkgver")
+replaces=('libnotify')
+
+source=("http://ftp.gnome.org/pub/GNOME/sources/${pkgname/-gtk2/}/0.7/${pkgname/-gtk2/}-${pkgver}.tar.xz")
+sha256sums=('0ef61ca400d30e28217979bfa0e73a7406b19c32dd76150654ec5b2bdf47d837')
+
+build() {
+ cd ${srcdir}/${pkgname/-gtk2/}-${pkgver}
+ # Force use GTK-2.0
+ sed -e 's/2.90/2.24/' -e 's/gtk+-3.0/gtk+-2.0/' -i configure.ac
+ autoreconf -fi
+ export ACLOCAL=aclocal
+ export AUTOMAKE=automake
+ export CC="gcc -m64"
+ export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
+ ./configure --prefix=/usr --libdir=/usr/lib
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname/-gtk2/}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}