summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWeby2020-04-06 03:54:43 +0200
committerWeby2020-04-06 03:54:43 +0200
commit67f9ab9f7d0aca28194b2bad6ae52e661a357b25 (patch)
treee12318fb12b189c38496c6620b1b7d1582898007
parent0b6833e97b843e61e9e7f6fff53935dd9c3347bf (diff)
downloadaur-67f9ab9f7d0aca28194b2bad6ae52e661a357b25.tar.gz
Updated to 0.7.9
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
2 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b81b74c1af09..c13e68891d9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = libnotify-id
pkgdesc = Desktop notification library
- pkgver = 0.7.8
+ pkgver = 0.7.9
pkgrel = 1
- url = http://library.gnome.org/devel/notification-spec/
+ url = https://developer.gnome.org/notification-spec/
arch = i686
arch = x86_64
license = LGPL
makedepends = gtk3
makedepends = gobject-introspection
+ makedepends = meson
depends = gdk-pixbuf2
- provides = libnotify=0.7.8
+ provides = libnotify=0.7.9
conflicts = libnotify
conflicts = libnotify-git
conflicts = libnotify-id-git
- source = http://ftp.gnome.org/pub/GNOME/sources/libnotify/0.7/libnotify-0.7.8.tar.xz
+ source = http://ftp.gnome.org/pub/GNOME/sources/libnotify/0.7/libnotify-0.7.9.tar.xz
source = https://launchpadlibrarian.net/105791133/print-and-replace-id-v3.patch
- sha256sums = 69209e0b663776a00c7b6c0e560302a8dbf66b2551d55616304f240bba66e18c
+ sha256sums = 66c0517ed16df7af258e83208faaf5069727dfd66995c4bbc51c16954d674761
sha256sums = 88655522acb5a4c1634de368e91ae79b4a8f205288bf4451e82e007266ba4fcb
pkgname = libnotify-id
diff --git a/PKGBUILD b/PKGBUILD
index 63b67d8c6ef9..511be1b26273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,36 @@
-# Maintainer: Justin Dray <justin@dray.be>
-
+# Maintainer: Nicolas Glassey <info@geeq.ch>
+
_pkgname=libnotify
pkgname=${_pkgname}-id
-pkgver=0.7.8
+pkgver=0.7.9
pkgrel=1
pkgdesc="Desktop notification library"
arch=('i686' 'x86_64')
-url="http://library.gnome.org/devel/notification-spec/"
-license=('LGPL')
-depends=('gdk-pixbuf2')
-makedepends=('gtk3' 'gobject-introspection')
+url="https://developer.gnome.org/notification-spec/"
+license=(LGPL)
+depends=(gdk-pixbuf2)
+makedepends=(gtk3 gobject-introspection meson)
conflicts=('libnotify' 'libnotify-git' 'libnotify-id-git')
provides=("libnotify=$pkgver")
source=("http://ftp.gnome.org/pub/GNOME/sources/${_pkgname}/0.7/${_pkgname}-${pkgver}.tar.xz"
'https://launchpadlibrarian.net/105791133/print-and-replace-id-v3.patch')
-sha256sums=('69209e0b663776a00c7b6c0e560302a8dbf66b2551d55616304f240bba66e18c'
+sha256sums=('66c0517ed16df7af258e83208faaf5069727dfd66995c4bbc51c16954d674761'
'88655522acb5a4c1634de368e91ae79b4a8f205288bf4451e82e007266ba4fcb')
prepare() {
- cd ${_pkgname}-${pkgver}
- patch -Np1 -i '../print-and-replace-id-v3.patch'
+ cd ${_pkgname}-${pkgver}
+ patch -Np1 -i '../print-and-replace-id-v3.patch'
}
build() {
- cd ${_pkgname}-${pkgver}
- ./autogen.sh --prefix=/usr --disable-static
- make
+ arch-meson ${_pkgname}-${pkgver} build
+ ninja -C build
}
+check() {
+ meson test -C build --print-errorlogs
+}
package() {
- cd ${_pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" meson install -C build
}
+