summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-04-13 13:51:04 -0500
committerCarlos Aznarán2024-04-13 13:51:04 -0500
commita98c9ef328d3af5d838fb7719e4df334462bace4 (patch)
tree3fe6c261eb7f9e66f75a4463e21da52ea29b6abb
downloadaur-a98c9ef328d3af5d838fb7719e4df334462bace4.tar.gz
Bump version to 1.0.1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD30
4 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..baf02151f7b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libnpy
+ pkgdesc = C++ library for reading and writing of numpy's .npy files
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/llohse/libnpy
+ arch = any
+ license = MIT
+ checkdepends = cmake
+ checkdepends = catch2-v2
+ checkdepends = python-numpy
+ makedepends = meson
+ source = libnpy-1.0.1.tar.gz::https://github.com/llohse/libnpy/archive/v1.0.1.tar.gz
+ sha512sums = faeff4f620025f1f5358498dcfb2eed97aa27ece2a9ee323d177d1dce149d029e0cb0d4a9b5b356027c651ab591e7bd75aa09b6c079b851c27444183e95ff16b
+
+pkgname = libnpy
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..5288aa3a7011
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[libnpy]
+source = "github"
+github = "llohse/libnpy"
+use_latest_release = "true"
+prefix = "v" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..022a2b179883
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+pkgname=libnpy
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="C++ library for reading and writing of numpy's .npy files"
+url="https://github.com/llohse/${pkgname}"
+arch=(any)
+license=(MIT)
+depends=()
+makedepends=(meson)
+checkdepends=(cmake catch2-v2 python-numpy)
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('faeff4f620025f1f5358498dcfb2eed97aa27ece2a9ee323d177d1dce149d029e0cb0d4a9b5b356027c651ab591e7bd75aa09b6c079b851c27444183e95ff16b')
+
+build() {
+ arch-meson ${pkgname}-${pkgver} build
+ meson compile -C build
+}
+
+check() {
+ cd ${pkgname}-${pkgver}
+ arch-meson tests builddir
+ meson compile -C builddir
+ meson test -C builddir --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+ install -Dm 644 ${pkgname}-${pkgver}/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}