summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2018-02-22 22:53:47 +0100
committerCarsten Teibes2018-02-22 23:38:48 +0100
commit9be5a6917c2c77a82aa2638d8a565b2b8b7cfdc4 (patch)
tree8cee54d2461a17da65484384c9a5e38a1b8a224c
parent70272f7164fa6d6eb8c9f1bab7b148671179f9d6 (diff)
downloadaur-9be5a6917c2c77a82aa2638d8a565b2b8b7cfdc4.tar.gz
[new] libnx 1.0.0
Remove old library with same name
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--LICENSE4
-rw-r--r--PKGBUILD57
-rw-r--r--README.md17
-rw-r--r--libnx.pc11
6 files changed, 48 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e841e07edf3c..cf41bc14f729 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-# Generated by mksrcinfo v8
-# Mon Feb 22 23:39:35 UTC 2016
pkgbase = libnx
- pkgdesc = Nanex NxCore tape processing library
- pkgver = 2.9.512
+ pkgdesc = Library for Nintendo Switch (NX) homebrew development
+ pkgver = 1.0.0
pkgrel = 1
- url = http://nanex.net
- arch = x86_64
- license = custom
- depends = gcc-libs
- source = LICENSE
- source = http://www.nanex.net/downloads/Linux/BETA/OLD/20151109.libnx.so.testing.tgz
- source = http://www.nanex.net/downloads/Linux/BETA/OLD/20141216.NxCoreAPIDU.tgz
- md5sums = 84bf6d4d8cf9e6597e8751dbe4f788f3
- md5sums = 674b616cae4bc0f1bf15690b0a119f18
- md5sums = 3bd43ad96641781079ad80e50197d876
+ url = http://devkitpro.org
+ arch = any
+ license = custom: ISC
+ depends = devkita64
+ noextract = switch-examples-20180218.tar.bz2
+ options = !strip
+ options = staticlibs
+ source = libnx-1.0.0.tar.gz::https://github.com/switchbrew/libnx/archive/v1.0.0.tar.gz
+ source = https://github.com/switchbrew/switch-examples/releases/download/v20180218/switch-examples-20180218.tar.bz2
+ sha256sums = 14bca9efe9b3c1d46c2f442bf09eaac2bd415ac7d27a1dddcd1af2428574aecf
+ sha256sums = 24b00060974e70be6ebf85addb35feb22146b1fcce28fb16b9c378097462b97b
pkgname = libnx
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 2da5f04d0de9..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,5 +0,0 @@
-*.xz
-*.gz
-pkg
-src
-*.tgz
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 2ef91afa4f86..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,4 +0,0 @@
-COPYRIGHT 2003-2015(c) Nanex, LLC, Winnetka, IL. ALL RIGHTS RESERVED.
-YOU MAY NOT TRANSMIT THE CONTENTS OF THESE FILES WITHOUT EXPRESS WRITTEN PERMISSION FROM NANEX, LLC.
-THESE FILES CONTAIN CONFIDENTIAL INFORMATION.
-SUPPORT: email: support@nanex.net
diff --git a/PKGBUILD b/PKGBUILD
index 7f1d468cbee5..fd9413da33bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,41 @@
-# Maintainer: Ben Alex <ben.alex@acegi.com.au>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=libnx
-pkgver=2.9.512
-pkgrel=2
-pkgdesc='Nanex NxCore tape processing library'
-arch=('x86_64')
-url="http://nanex.net"
-license=('custom')
-depends=('gcc-libs')
+pkgver=1.0.0
+_pkgverexamples=20180218
+pkgrel=1
+pkgdesc="Library for Nintendo Switch (NX) homebrew development"
+arch=('any')
+url="http://devkitpro.org"
+license=('custom: ISC')
+depends=('devkita64')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/switchbrew/libnx/archive/v$pkgver.tar.gz"
+ "https://github.com/switchbrew/switch-examples/releases/download/v$_pkgverexamples/switch-examples-$_pkgverexamples.tar.bz2")
+sha256sums=('14bca9efe9b3c1d46c2f442bf09eaac2bd415ac7d27a1dddcd1af2428574aecf'
+ '24b00060974e70be6ebf85addb35feb22146b1fcce28fb16b9c378097462b97b')
+noextract=("switch-examples-$_pkgverexamples.tar.bz2")
+options=(!strip staticlibs)
-source=('LICENSE'
- 'http://www.nanex.net/downloads/Linux/BETA/OLD/20151109.libnx.so.testing.tgz'
- 'http://www.nanex.net/downloads/Linux/BETA/OLD/20141216.NxCoreAPIDU.tgz')
-md5sums=('84bf6d4d8cf9e6597e8751dbe4f788f3'
- '674b616cae4bc0f1bf15690b0a119f18'
- '3bd43ad96641781079ad80e50197d876')
+build() {
+ # set environment
+ source /etc/profile.d/devkita64.sh
+
+ make -C libnx-$pkgver
+}
package() {
- cd ${srcdir}
- mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- cd ${srcdir}/20141216.NxCoreAPIDU/NxCoreDU
- install -Dm644 NxCoreAPIDU.h ${pkgdir}/usr/include/NxCoreAPIDU.h
- install -Dm644 NxCoreLoadLib.h ${pkgdir}/usr/include/NxCoreLoadLib.h
- cd ${srcdir}/20151109.libnx.so.testing/CentOS-x64-63_gcc-4.7.2-O3_v2.9.512
- install -Dm644 libnx.so ${pkgdir}/usr/lib/libnx.so
+ cd libnx-$pkgver
+
+ make -C nx dist-bin
+ DEVKITPRO="$pkgdir/opt/devkitpro"
+ install -d "$DEVKITPRO"/libnx
+ bsdtar xf nx/libnx-$pkgver.tar.bz2 -C "$DEVKITPRO"/libnx
+ # examples
+ install -d "$DEVKITPRO"/examples/switch
+ bsdtar xf ../switch-examples-$_pkgverexamples.tar.bz2 -C "$DEVKITPRO"/examples/switch
+ # fix permissions
+ chown -R root:root "$DEVKITPRO"/examples
+ find "$DEVKITPRO"/examples -type d -exec chmod +rx "{}" \+
+ # license
+ install -Dm644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/README.md b/README.md
deleted file mode 100644
index 6233ade68efb..000000000000
--- a/README.md
+++ /dev/null
@@ -1,17 +0,0 @@
-Source for the
-[Nanex NxCore](http://nanex.net/)
-AUR package
-[libnx](https://aur.archlinux.org/packages/libnx/).
-
-Build and Test
---------------
-If you'd like to try out changes to the package, these commands offer a start:
-
-```
-rm -rf pkg src *.xz && makepkg -f
-namcap -m *.xz
-sudo pacman -U *.xz
-mksrcinfo
-git commit -a -m "new version"
-git push
-```
diff --git a/libnx.pc b/libnx.pc
deleted file mode 100644
index fb273f34fca7..000000000000
--- a/libnx.pc
+++ /dev/null
@@ -1,11 +0,0 @@
-prefix=/usr
-exec_prefix=${prefix}
-libdir=${exec_prefix}/lib
-includedir=${prefix}/include
-
-Name: libnx
-Description: Nanex NxCore tape processing library
-Version: 2.9.472
-Libs: -L${libdir} -lnx
-Libs.private: -ldl
-Cflags: -I${includedir}