summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2015-07-02 16:53:27 +0200
committerMiguel Revilla2015-07-02 16:53:27 +0200
commitbbe9fcb5f33f799aed975c28b4e27c74c27f3540 (patch)
tree68d0e57c80558b698d10b11dc70ad3982ebeb022
downloadaur-bbe9fcb5f33f799aed975c28b4e27c74c27f3540.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4da129e4f18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libodb-boost
+ pkgdesc = The ODB boost profile library
+ pkgver = 2.4.0
+ pkgrel = 1
+ url = http://www.codesynthesis.com/products/odb/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libodb
+ depends = boost-libs
+ options = !libtool
+ source = http://www.codesynthesis.com/download/odb/2.4/libodb-boost-2.4.0.tar.bz2
+ md5sums = 6b0127619cab3244ae838780db890b9d
+
+pkgname = libodb-boost
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3098fcfcc74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Miguel Revilla <yo@miguelrevilla.com>
+# Contributor: Miguel Revilla <yo@miguelrevilla.com>
+
+pkgname=libodb-boost
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="The ODB boost profile library"
+arch=('i686' 'x86_64')
+depends=('libodb' 'boost-libs')
+url="http://www.codesynthesis.com/products/odb/"
+options=('!libtool')
+license=('GPL')
+source=("http://www.codesynthesis.com/download/odb/2.4/libodb-boost-${pkgver}.tar.bz2")
+md5sums=('6b0127619cab3244ae838780db890b9d')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr --libdir=/usr/lib/odb --with-pkgconfigdir=/usr/lib/pkgconfig --with-libodb=/usr/lib
+ make ECHO=echo
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make ECHO=echo DESTDIR="${pkgdir}" install
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}