summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimPilotAdamT2022-11-22 07:49:18 +0000
committerSimPilotAdamT2022-11-22 07:49:18 +0000
commit35f60c985c7c177f557dad897a4d88a507bd402d (patch)
tree2d2fa5f707497c4e3cf2add5038ccc716dfbd85a
parentda40505e735e20835a7190bbb2abd53dcccd014f (diff)
downloadaur-35f60c985c7c177f557dad897a4d88a507bd402d.tar.gz
Using a newer repo
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c640bd0c8c79..00e40cc82bc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,14 +2,13 @@ pkgbase = liboffsetfinder64-git
pkgdesc = i64bit offsetfinder. It finds offsets, patches, parses Mach-O and even supports IMG4
pkgver = 1
pkgrel = 1
- url = https://github.com/tihmstar/liboffsetfinder64
+ url = https://github.com/Cryptiiiic/liboffsetfinder64
arch = x86_64
- license = unknown
+ license = LGPL-2.1
makedepends = libplist
- source = git+https://github.com/tihmstar/liboffsetfinder64.git
+ source = git+https://github.com/Cryptiiiic/liboffsetfinder64.git
source = libgeneral.patch
sha512sums = SKIP
sha512sums = 8e055ce5021bc983e0a3bc459728b6035842f5a46706e4f047f22e0c55a7eeaf2a0581e904f9342b3baff34c394a7b7db644c474f7e59548f133e256e79ce695
pkgname = liboffsetfinder64-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 75404049a78f..eda778fe1c7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,25 @@
# Contributor: Jonas Heinrich <onny@project-insanity.org>
pkgname=liboffsetfinder64-git
+_pkgver=1
pkgver=1
pkgrel=1
pkgdesc="i64bit offsetfinder. It finds offsets, patches, parses Mach-O and even supports IMG4"
arch=('x86_64')
-url="https://github.com/tihmstar/liboffsetfinder64"
-license=('unknown')
+url="https://github.com/Cryptiiiic/liboffsetfinder64"
+license=('LGPL-2.1')
makedepends=('libplist')
-source=("git+https://github.com/tihmstar/liboffsetfinder64.git"
+source=("git+https://github.com/Cryptiiiic/liboffsetfinder64.git"
"libgeneral.patch")
sha512sums=('SKIP'
'8e055ce5021bc983e0a3bc459728b6035842f5a46706e4f047f22e0c55a7eeaf2a0581e904f9342b3baff34c394a7b7db644c474f7e59548f133e256e79ce695')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ __pkgver=$(echo "$_pkgver.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)" | rev | cut -c 2- | rev)
+ echo "$__pkgver"
+}
+
prepare() {
cd "${srcdir}/liboffsetfinder64"
git submodule update --init external/libgeneral