summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-03-19 18:06:39 +0800
committerChocobo12017-03-19 18:17:03 +0800
commitb76b3e20873c8ce34b6b098d594f2df3f591956f (patch)
treeef65e08ab2cef187093709209535a0ecb274d30f
downloadaur-b76b3e20873c8ce34b6b098d594f2df3f591956f.tar.gz
newpkg: libogg-git 1.3.2.r36.gcab46b1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74a8bca67d39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libogg-git
+ pkgdesc = Reference implementation of the Ogg media container
+ pkgver = 1.3.2.r36.gcab46b1
+ pkgrel = 1
+ url = https://www.xiph.org/ogg/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ provides = libogg
+ conflicts = libogg
+ source = git+https://git.xiph.org/ogg.git
+ sha256sums = SKIP
+
+pkgname = libogg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7874e541c9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libogg-git
+pkgver=1.3.2.r36.gcab46b1
+pkgrel=1
+pkgdesc="Reference implementation of the Ogg media container"
+arch=('i686' 'x86_64')
+url="https://www.xiph.org/ogg/"
+license=('BSD')
+makedepends=('git')
+provides=('libogg')
+conflicts=('libogg')
+source=("git+https://git.xiph.org/ogg.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "ogg"
+
+ git describe --long --tags | sed 's/^[A-Za-z]*//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "ogg"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+
+ make
+}
+
+package() {
+ cd "ogg"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/libogg/COPYING"
+}