summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2023-02-05 18:44:54 -0300
committerTércio Martins2023-02-05 18:44:54 -0300
commitb27ecc315b238fe037f31f3fbf7c7453ae625139 (patch)
treed35f9af2d8f320125c60419d1f64bb1ea50aa1ea
downloadaur-libolivecore-git.tar.gz
Initial package upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c61ade026e4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libolivecore-git
+ pkgdesc = Common components shared between Olive libraries
+ pkgver = r12.953ee66
+ pkgrel = 1
+ url = https://www.olivevideoeditor.org/
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = ffmpeg
+ makedepends = git
+ makedepends = imath
+ makedepends = ninja
+ makedepends = opentimelineio
+ provides = libolivecore
+ conflicts = libolivecore
+ source = git+https://github.com/olive-editor/core.git
+ sha512sums = SKIP
+
+pkgname = libolivecore-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df499c6bc293
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=libolivecore-git
+pkgver=r12.953ee66
+pkgrel=1
+arch=('x86_64')
+pkgdesc=" Common components shared between Olive libraries"
+url="https://www.olivevideoeditor.org/"
+license=('GPL3')
+makedepends=('cmake' 'ffmpeg' 'git' 'imath' 'ninja' 'opentimelineio')
+provides=('libolivecore')
+conflicts=('libolivecore')
+source=('git+https://github.com/olive-editor/core.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd core
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd core
+ cmake -GNinja \
+ -Bbuild \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DOTIO_DEPS_INCLUDE_DIR=/usr/include/opentimelineio
+ ninja -C build/
+}
+
+package() {
+ cd core
+ DESTDIR="$pkgdir" ninja -C build/ install
+}