summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2015-11-27 08:16:36 +0100
committerWilken 'Akiko' Gottwalt2015-11-27 08:16:36 +0100
commit23bf2b366ddb6bb8d38c785a8d07759d00b1dfde (patch)
treef4ef1aa01f1cf9fc534e216aac7587b1ec2bbff6
downloadaur-23bf2b366ddb6bb8d38c785a8d07759d00b1dfde.tar.gz
Initial commit of OpenMAX Bellagio ALSA component build script including
64 bit fix.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
-rw-r--r--libomxalsa_64bit.patch23
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ef6019f332b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libomxil-component-alsa
+ pkgdesc = An opensource implementation of the OpenMAX Integration Layer API - ALSA component
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://omxil.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = glibc
+ source = http://downloads.sourceforge.net/project/omxil/components/libomxalsa-0.1.tar.gz
+ md5sums = 39273f12cc916f70b1758244cf8e61c4
+
+pkgname = libomxil-component-alsa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3501f9f82686
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+# Contributor: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+pkgname=libomxil-component-alsa
+pkgver=0.1
+pkgrel=1
+pkgdesc="An opensource implementation of the OpenMAX Integration Layer API - ALSA component"
+arch=('i686' 'x86_64')
+url="http://omxil.sourceforge.net"
+license=('LGPL')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/project/omxil/components/libomxalsa-${pkgver}.tar.gz")
+md5sums=('39273f12cc916f70b1758244cf8e61c4')
+
+prepare() {
+ cd ${srcdir}/libomxalsa-${pkgver}
+
+ [ -f Makefile ] && make distclean
+ patch -Np0 -i ../../libomxalsa_64bit.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd ${srcdir}/libomxalsa-${pkgver}
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${srcdir}/libomxalsa-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/libomxalsa_64bit.patch b/libomxalsa_64bit.patch
new file mode 100644
index 000000000000..ef213cf50387
--- /dev/null
+++ b/libomxalsa_64bit.patch
@@ -0,0 +1,23 @@
+proper memory address printf
+
+Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+--- src/omx_alsasrc_component.c.orig 2015-11-27 08:11:05.900704408 +0100
++++ src/omx_alsasrc_component.c 2015-11-27 08:12:34.199888214 +0100
+@@ -120,14 +120,14 @@
+ return OMX_ErrorHardware;
+ }
+ else
+- DEBUG(DEB_LEV_SIMPLE_SEQ, "Got playback handle at %08x %08X in %i\n", (int)omx_alsasrc_component_Private->playback_handle, (int)&omx_alsasrc_component_Private->playback_handle, getpid());
++ DEBUG(DEB_LEV_SIMPLE_SEQ, "Got playback handle at %p %p in %i\n", &omx_alsasrc_component_Private->playback_handle, &omx_alsasrc_component_Private->playback_handle, getpid());
+
+ if (snd_pcm_hw_params_malloc(&omx_alsasrc_component_Private->hw_params) < 0) {
+ DEBUG(DEB_LEV_ERR, "%s: failed allocating input pPort hw parameters\n", __func__);
+ return OMX_ErrorHardware;
+ }
+ else
+- DEBUG(DEB_LEV_SIMPLE_SEQ, "Got hw parameters at %08x\n", (int)omx_alsasrc_component_Private->hw_params);
++ DEBUG(DEB_LEV_SIMPLE_SEQ, "Got hw parameters at %p\n", omx_alsasrc_component_Private->hw_params);
+
+ if ((err = snd_pcm_hw_params_any (omx_alsasrc_component_Private->playback_handle, omx_alsasrc_component_Private->hw_params)) < 0) {
+ DEBUG(DEB_LEV_ERR, "cannot initialize hardware parameter structure (%s)\n", snd_strerror (err));